Gstreamer - Help

Please, yesterday I receive my new Navio2, everything is working fine (APM, 3G, etc…etc…)

but Gstreamer I can’t fix, I used the syntax in the DOCs

first try:
“sudo apt-get install gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-libav”

Second try:
“sudo apt-get install gstreamer1.0”

And already tried to install the gstreamer tools, but without success.

I know I cant do Apt-get update.

Now I receiving this message when I try to RUN :
“WARNING: erroneous pipeline: no element "rtpbin"
And when I tried install gstreamer again this message :
Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libtiff5 armhf 4.0.3-12.3
404 Not Found [IP: 5.153.225.207 80]
Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libgraphite2-3 armhf 1.2.4-3
404 Not Found [IP: 5.153.225.207 80]

Any idea ?

Try to change the apt source server. (I also had several 404 errors using default server)

nano /etc/apt/sources.list

Example; using the UK server.
deb http://mirror.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian jessie main contrib non-free

Then run
apt-get update

Install Gstreamer
apt-get install gstreamer1.0

Complete server list

Thanks, I will try soon.
But can I run “apt-get update” ?
if I’m not wrong this is bad for this kernel (Navio2), as follow:

Emlid Raspbian Image for Navio2
Please do not perform apt-get upgrade on this image as it will overwrite our custom kernel. An image that will handle updates properly is in the works.

Update should be okay, upgrade is not currently.

Cristal clear, tks.

Tomorrow I will assembly my new quadcopter with Navio2.

Everything is working fine now after “apt-get update”
This weekend I will do the first field test.

Only one important thing, I had to attach more power to the RPI2 USB, using a 5v 5A BEC.

Because when I started the camera (USB Logitech C920 Web camera) the 3g modem drop.

After this small hw change, everything is working fine.

In this photo the jumper from Navio2 servo rail to RP2 USB. (If you want I can post the place into RP2), but there is a step by step very well done in UAV Matrix Site, more detailed.


3 Likes