Emlid

Community Forum

GPS working but "Not Seen" in Mission Planner


(Phil) #1

Hi
Mission Planner is showing No GPS, and gpsstatus, gpshdo & satcount are all zero on the Tuning graph.

I have run the GPS.py example on the RPi, and that gives a 3D fix, and a correct location. The device, antenna, and SPI therefore all seem to be OK.

I’m really not sure where to look next. Any help appreciated.

Navio2. Arducopter 3.5.2-2.0 (according to dpkg)
Linux 4.9.45-94f47ec-emlid-v7+

The copter has been on the bench for a few months while I’ve been experimenting with a gimbal, Mavlink and Dronekit. I wouldn’t have expected any of this to have impacted the GPS.

Look forward to any help
Phil


(Tatiana Andreeva) #3

Hi @phil1,

Please post here:

  • the photo of your hardware setup;
  • screenshots of MP demonstrating the issue.

Thanks!


(Phil) #4

Thanks for getting back

RC is at the bottom of picture (front)
PSU and RTC on left
5GHz Wifi antenna at the top of picture

This arrangement has flown in the past without any problems.
GPS.py still giving 3D fix (not shown)

image

No GPS flagged in MP
Various GPS stats are zero in the graphs

What’s the best way of checking that GPS telemetry is actually being sent??

Phil


(Tatiana Andreeva) #5

Hi @phil1,

Have you tested it indoors or outdoors?
Please note that GPS antenna requires a clear sky view without obstacles.

I also recommend you to provide a ground plane for the antenna.


(Marc Lebret) #6

Hello,

Could be a bad setting:

You can check, menu " Config/Tuning", Full parameters tree, GPS parameters.

GPS_TYPE should be set at 1 (Auto) or 2 (uBlox). If set to 0 (none) you have the msg “No GPS” in your screen.


(Phil) #7

Getting closer!!

The problem was that I had disabled SERIAL3_PROTOCOL (as well as 4 and 5) because I was not using them - I thought. All working normally now.

So it appears that SERIAL3_PROTOCOL needs to be defined as a GPS in order for the internal GPS to work, even though there is no arducopter -B option specified on startup. The SERIAL3_BAUD parameter presumably is ignored as the GPS is connected via SPI rather than a serial link.

Any thoughts on why it should be so?

Thanks for the help all
Phil


(Marc Lebret) #8

Here we are: https://docs.emlid.com/navio2/common/ardupilot/installation-and-running/#specifying-launching-options

Serial3 parameters:

Serial3baud 38
Serial3protocol 5 (Gps)

Marc


(Phil) #9

That’s understood…
The point I was trying to make was that SERIAL3_PROTOCOL MUST be set to 5 for the INTERNAL GPS to work. I wasn’t expecting that.

cheers
Phil