GPS no lock please help

Hello folks, my project is hexacopter with afro esc 30A firmware 3.3, dragonlink receiver, since i have upgraded to 3.3 i canot get a gps lock, yes everything was working fine before.
I just tried the u center, no sats on MP as well. I reflash the SD card, i did all the config that i could, i have read all topics about this, BTW i didnt have any problem with wiring, everything related to instalation seems perfect but still no gps lock, on MP i have GPSSTATUS 1, HDOP 99,99 SATCOUNT 0, last time i tryied i waited for 7 minutes with no lucky at all.
I appreciate all the help i can get.
In time, no FPV gear yet, just basic, i mean no interference from external transmitters.

Hello Domingos,

It would greatly help troubleshooting if you could login in you Raspberry Pi over SSH and forward GPS stream to u-center (without APM running) and post sats signal levels.

Please also post a picture of your setup, maybe we can spot something.

What are the conditions? Open sky view?

Hello Igor, i appreciate your attention, you have attached the pics, today i reflashed the SD card and tried it again, i had GPS green light but, in flight during loitter the hexa was behaving strange, i see like a toilet bowl effect, it is flying in circular pattern and the RTL is unstable like searching for the right spot finally landing 8 meters from take off. Hopefully we can find something.

In time: The link for the RT kernel is broken at the page:

An update on this issue, yesterday i flew it again, the GPS light came on after 2 min, the loitter mode is unstable, in flight there is no diference from ATL HOLD to LOITTER i mean it maintain the altitude but not the position, even with green light(LED) and RTL didnt work. During the ublox test, the GPS is perfect, i have full GPS coverage, 3D really fast, it seems like when i start the APM something is not behaving the way it should, i am a newbie, what is helping me is my previous experience with PIXHAWK.


Could you post the logs from that flight?

Yes Igor, thanks a lot for your help, i dont think it has anything to do with the issue but, i flew the Navio+ before in a quad and 3.2.1 firmware(i think) and i had no problems, after i setup my hexa and the 3.3 firmware, i had no success. I really like Navio+ but i need to see it flying again as before. You will find attached the logs.

Looking through your logs it seems like GPS performance is fair. I will have a deeper look into the logs…

I Hope you find something.

Igor you have 2 print screen, Mission planner running at the same time with ublox. Ublox show 3d fix and MP shows “No Fix”.

Igor during the barometer test i noticed that when APM is running the temperature and pressure oscilates a lot. Apm not running temp and pressure is pretty steady. Following screen pics with the tests, is this normal?


APM and Navio example programs are using the same resources which leads to conflicts and distorted values.
Please do not run any of the examples while running APM, especially in flight.

Good to know, ok i will never try in flight.

Hello Igor, did you have chance to check my logs?

Today i reflashed the SD once again, i`ve followed all the lines from the docs and flew this time a quadcopter, This setup has been flown before so i am sure everything is ok with it but, Navio+ is doing the same, gps lock (green led) took me 1 min and as soon as i armed it the blue led came on. I rebooted it and in flight it is not holding position, if someone is having problems like these please share ideas on how to fix it. I connected it to ublox, gps is behaving ok during the test, all the problems only show up when APM is running.
My Setup this time:
DJI F450 quad
Sunnysky motors 2216 800KV
Afro 30a Simonk ESCs
10x4.5 APC props
5000 mah 4S gens ace Batt
It was doing perfect before( firmware 3.2, i believe) but as soon as i upgraded it to 3.3 all this problems came up.
I appreciate all of you that can help.

Hello Emlid, my problem still persists, do you have any clue? Please let me know whatelse needs to be done to fix it. Thanks.

My issue with the GPS has been solved, thanks Denis at Emlid. I have a new antena and my quad is working good now. GPS lock really fast 13 sats when the sky was overcast.

1 Like

Hi, how do you fix the gps lock problem? Seems mine have that problem now and bad baro.
It wouldn’t get armed.


Hi, i was suspecting on the cable and in contact with emlid they have sent me a new antena, which has fixed it. Now i have gps lock really fast and in open area i get up to 13 sats. I also connected a 3DR GPS via UART and it worked perfectly. So all my suspects on the MCX antena were confirmed. For the BARO problem, did you try reflashing the SD card and restart from zero? Dont forget to format the SD first.

Yes I have try re flash it from zero and always format it first… still no luck with my GPS and Baro now.

Ok you did your best, now i guess you need to contact emlid, they will address your problem properly. I am sure you will get it to work.