GPS is unstable


i have noticed in the last week that suddenly the GPS stopped working like it used to do. I always had a very good signal with HDOPs around 0.6 and Nstats around 16.
But the real problem now is that some times (often) the GPS cannot get a signal at all.
TOday it happened again… SO I started my first flight in open air with the first battery and I had a 3D Fix with NSat around 12 and HDop around 1. In this flight my raspi camera was on and was recording. My camera and camera cable have that copped shield tape all around. I landed and then i continued my flight for a couple more minutes because i had some more battery juice left. Attached you can find the two log files from these two flights. (4.4 MB) (988.3 KB)

So after landing i changed the battery in order to continue with another flight. (There is no log files for this session because i didnt even managed to get my copter to armed state). As soon as I powered my Navio2, I had a HDOP of 100 and NSats 0. After some time it managed to get HDOP 2 AND NSats 4… I waited but the values remained the same. I restarted Navio2 two times but always the same…I should mention that my rasperry camera was off !!!
This erratic behavior happens the last week and it is so annoying … I cannot understand what is happening and i cannot identify the source of this problem because sometimes it happens and sometimes it does not. I am using your latest image and arducopter v3.4.6
Please give me your help on this issue…

Best Regards,

@drone_newbie Hi! That sounds like a cable/connector issue, could you please try moving the cable a bit and see if it makes any difference?

so you mean the cable of the GPS antenna ?? I have already tried to move it … For example while i had a good gps signal (e.g Nsat 13 ) i was moving the cable around the MCX connector… But I didnt see the signal getting affected…
If it was a cable/connector issue, shouldnt it change the gps signal while i was moving the cable around ???

thorough check of your gps antenna cable and connector is definitely recommended;
you could also try to place your telemetry modem antenna further away from your gps antenna;

how can i further check the connector and cable ??? by vision i cannot see anything wrong on them … I have just installed the gps cable on my navio and i havent been taking it on and off since then…
Also i dont have telemetry antennas… Im connecting to my GCS through UDP which means that i have a 3g modem onboard… 3G modem should not be the problem because so far the GPS signal was always great…

I did have different issues with my rover, regarding steering and gps. Both times a reinstall of the SD card corrected the problems. I suspect the config file or the APM binary itself got corrupted somehow. Save your config with missionplanner. You can try and restore it after reinstall. It worked for me at least once, if I remember correctly.

Sebastian could be right, could you please try to reinstall the SD card and let us know?

OK… I will finish my network setup and processses and when i finalize this i will proceed with reinstall of sd card and let you know…