GPS glitches & weird behaviour

Hello everyone,
I have build a drone which I carefully designed in every aspect to fulfill my expectations and compatibility.
This drone is now my Development Platform and I’ve flown it now for 2-3 hours so far without any issues. All peripherals are working perfectly together.

Yesterday I was flying the drone and it worked perfectly, I landed it, swapped the battery and wanted to go on the second run, when suddenly, just after lift off, GPS glitches came up.
I was able to prevent the drone from flying in the next tree, than the GPS Failsafe kicked in, an the drone landed in the wheat field, before I could switch the flightmode to stabilize.
Luckly nothing was damaged.
I was ready for the next try, but the GPS failsafe appeared again and cleared in random intervalls.
This was very strange, I thought someone was jamming the GPS.

Today I tested it again back home, and the GPS keeps unhealthy.

Than I checked the gps module with u-center:
This is what u-center does:!AglWdwY-qBjOgaIqUBRE4Wy0IYZjLA?e=zNreyN
As you can see, the Module has a 3D Fix and a very good accuracy
but in random intervalls it cuts off for a short amount of time.

It wasn’t clear for me if something is wrong with the antenna or with the module or its SPI connection. Unfortunately, I don’t have another GPS antenna to test it out.

I tested the GPS with the Navio2 Python Tools:

But it doesn’t work anymore.

But the emlid tool says it is all fine:

Did anyone had a similar problem before ?
Maybe it is possible to make a firmware update to the ublox module?

This is the UBLOX u-center recording of the problem.
maybe someone can find more information from the log, than me.!AglWdwY-qBjOgaIsOGaTFF7M9M3JkQ?e=a6x29h

Hi @MCMH2000,

Thanks for the detailed description of the issue.

What antenna are you using with Navio2? I can’t seem to find the antenna on the photo of your copter.

If you’re using the patch antenna that comes with Navio2, please note that we recommend placing it on the ground plane. It should be raised above all the other electronic components. This way, the antenna can obtain the satellite’s signal fine, and the signal won’t be affected by RF noise.

I’m using the stock antenna that comes with the Navio2.
I just removed the plastic to reduce weight and to solder a longer cable to it.
I resealed everything, so no water can get in.

As you can see I have outsourced the antenna to the top of the arm so it has a a distance of 35 cm to the main electronics and 55cm to the next antenna to reduce as much interference possible in this setup. The GPS antenna sits on the ESC but the ESC itself is shielded with a 2mm thick aluminum plate and is surrounded by multiple layers of aluminum tape.

So as I said, this setup is working really well, i have now more that 2-3 hours of flight time with this drone and never experienced any issues until the day before yesterday. Also the GPS reception is flawless with horizontal accuracy of less than a meter and satellite counts between 14 and 19 with optimal signal strengh. No interferences.

Also loose contacts are out of question, because the issue still exists also when the drone is just sitting on the ground without moving anything.

I think the problem seems to be the ublox module. If you see my recording and the logfile from u-center, it seems like the module looses connection. And also the script is not working anymore. I tested it all.

How did you solder a shielded RF antenna cable?

Well, like it should be done.
This is not my first antenna modification. I build antennas for a long time now to match my needs.
And so did I with the other much more filigree antenna cables of my vtx and crossfire antennas.
I even checked the cables and antennas with my VNA to make sure the cables and antennas are working like they should. Also all cables are of course long enough to not be exposed to tension etc.

When you watch my recording of u-center you see, that the reception is fine but it cuts in random intervals. if the antenna or the cable has some issues, than nothing should be received.
If something gets shorted or looses connection I would not have an active connection to 19 satellites. Of course the recording was made with the drone still standing on the ground.

Hi @MCMH2000,

I’ve checked the log you shared in the u-center. As I see it, Navio2 loses track of the satellites at random time intervals. This signal disruption might cause the error of the Unhealthy GPS Signal. Usually, similar issues are caused by electronic devices that produce RF noise to the signal.

However, to understand whether the setup causes the issue for sure, it might be useful to conduct the following test. Please disconnect the antenna with Navio2 from other drone parts and place it under the clear sky view. Then, please run Python and C++ GPS example and post the output here. You can follow the instructions from this guide.

Also, I recommend revising the GNSS antenna placement on the drone. The patch antennas are susceptible to radiation from the backside of the antenna. No components should be mounted near it.

I have disconnected all electronics, so only the Raspberry Pi with Navio2 is running.
I also connected a new out of the box GPS antenna to the Navio2 with a long cable and placed it far away. But as I thought before, the problem is still there.
Here is a video:!AglWdwY-qBjOgaIuhqLEfD3maK4STg?e=GzRSA6

The C++ GPS and Python GPS output is here:
Python is still not working, but I can get data with the C++ example.

So the SPI connection is also working fine what makes me think that some internals of the GPS module itself causes problems.

So, what can I do now?
I think I can try updating the firmware of the ublox module via u-center.
If this is not working, I can replace the module on the Navio2 board.
In both cases: can you provide a configuration file for setting up the ublox module after update or replacement?

However, the board is barely one year old. Are there any warranty or replacement options?

I know this is a hard topic, but not answering at all does not help very well. :upside_down_face:

Hi @MCMH2000,

Sorry for the delay! We’ve discussed your case with the team. It looks like there are indeed some issues with the GPS module on your board.

Please check your PMs. I’ve written to you there. The further steps may require sharing sensitive information that’s why it’s better to handle it in the private chat.

After replacing the Board, everything is working fine again.
Thank you very much for your support. :blush:

1 Like