Gps Fix problem

Best regards From Croatia.

We bought Reach RTK, and started testing it for the last few days.
Only once we had gps fix signal, that was after 15m from strating base and rover, after that we made over 20 tests and solution status is always “FLOAT”. We made ground planes as seen in your documentation and put modules on elevated positions with clean sky view.
Thera are some photos:

Ground planes

Instalation of rover

Base instalation

We tried to change RTK settings positioning mode, GPS AR mode, tried to turn on and off GLONASS AR mode, changed value of elevation mask angel to reduce noise, changed selection of gnss and updated rate and the results are always same.
Do you have some advice how to get GPS FIX ?
Thanks a lot.,

Are measuring a static point or driving around?
Start rover of with GPS only,15degreed mask, 1hz kinematic and AR gps on.
Do you have screen of base setting?
Also, you need reach you settle for a bit after each change. At least 3min

Booth modules are static 30 m away one from other.
I was waiting 2 hours and finaly get fix signal but only for 5 minutes the again float and sometimes fix.
There is photo of base settings :

I tried to set mask on 15, 20 and 30 degrees and results were same.
I will try your advice now.

Also switch to continuous. And post a picture of base setting please

You mean this picture

Yeap, thanks. Looks ok.
Give a shoot with above settings and let it work for 3-4 minutes
Edit: For static measure, use static.

Ok Tnx
I set 1Hz update rate on both modules,
And set static.
I will let you now soon.

Now is ok but after 15 minutes goes in fx

while i was tayping it goes again in float mode.

If you are not moving Reach ? it could be multipath issue. By the looks of spread fixed dots
Any cables hanging nearby or other RF appliance?

I think there is no other RF appliance or cables, but I can test it on other location.
And send results again.
Thank you very much.
After 30 minutes fix is there and it is stable.


If acceleration is truly set at 0M/sec^2 would that not significantly slow down convergence to fix? I think I have experienced that and increased the acceleration to a higher value.

It was same with acceleration of 1m/s2,
I can try set it on default value with parameters o f TB_RTK

Thanks. I have problems from time to time getting fix, but my skyview is not great in my test area. Also, did you try switching SBAS off. Sometimes it affects RTK here in US.

I tested RTK this morning in static conditions on different location and results were great,
it goes in fix mode after 2 minutes and stayed for whole testing time. I think that SBAS covers Europe.
Later I will test it in dynamic conditions.
P.S. Also changed acceleration from 0m/s^2 to 1m/s^2

Great! Glad to hear you are making progress. RTKLIB is a very comprehensive and adaptable program. Emlid sets default parameters to optimize for diversity of applications. Obviously, they can’t cover them all, but do a good job.

I recommend reading RTKexplorer blog for fine details of RTKLIB . And, of course, this Forum is full of experienced Reach users that are helpful.

1 Like

On a similar note, I’m having issues getting my rover to “Fix”. I have great satellite coverage, and took a 30 minute point on the base as the position. The solution status remains single. Additionally, the age of differential is ~550 seconds, which seems like way too long. AR ratio is 0.0. Rover is not moving and is taking points.

Any help would be great!

Sounds like you are losing base to rover corrections. Do you have Base satellites showing on Rover Screen?

I’ll leave it others to check your data link…