Emlid

Community Forum

GPS does not work after updated 20190227


(Huy Vu) #1

Hi, I am using Navio2 and I have this question
After updated emlid raspbian 20190227, I run GPS examples on both c++ and python and saw this


I have connect the GPS antenna from emlid
Please have me! Thank you


(Tatiana Andreeva) #3

Hi @vqh2308,

We tested this example with the new raspbian image. However, we weren’t able to reproduce the issue.

So, the issue barely can be caused by an update to the new version. It’s more likely there is something wrong with your hardware setup.

Please check the antenna connection and make sure you’ve provided the clear sky view.
Do you have another antenna to test with it?

Could you please share your hardware setup photos as well?


(Huy Vu) #4

Thanks for replying me!
After started for about 10 mins, the GPS works normally. But 10 min is too long and it will consume much power. Do you know how to fix that?


(Tatiana Andreeva) #5

Hi @vqh2308,

It’s hard to say certainly why it might occur as there is not enough information. May I ask you to provide photos of your hardware setup?

Could you please clarify how exactly it behaves in the first 10 minutes? It’d be great to see screenshots or screen recording showing it.


(Huy Vu) #6

After reading several post about GPS problems, I figure out that GPS only work outdoor, indoor sometimes does sometimes does not. Therefore I tried and it succeeded.
Anyway, thanks for answering my questions