GPS and Baro Problem

Hi Community,

I have still an GPS and Baro problem with NAVIO+

flashed with

use sudo ArduCopter-quad -C /dev/ttyAMA0
connect well with RFD900+ at MP, APMPlanner2 or QGroundControl

setup at MP with

G_GNSS_MODE 64 (default 0)

this enables GPS, SBAS, GLONASS
you might have to change that, depending on where you live.

GPS_SBAS_MODE 1 (default 0)

GPS_TYPE 2 (default 1)

from Navio+/2 GPS problems (hopefully) solved

But still have those problem, several times calibrate accel but still bad baro health.

Your advice and help are needed


Can you share more details about your setup? Is baro working at all?

Here is the screenshot of MP

This is my quad

Any suggestion on check the baro? Do I need like at ?


Barometer test

GPS test

My quad are outside the room with clear view of the sky.

I also attach PX4Flow and it doesn’t send or receive any data…

Can you try with all external i2c devices disconnected first?

Yes I have try it, try only raspi navio+ gps powered from PM but still the same

Johar, baro test looks really suspicious. can you try to SSH into the Rpi, instead of using GUI and run the test again? Also, please do not run tests and APM at the same time.