Got My New REACH RS+ (but a few questions)

Hello from a new user:

I just received my REACH RS+ last Friday, and have been having a blast. But a few questions.

My setup is just a single Reach RS+, but my state (Minnesota, USA) has a great free CORS
system, giving GPS and GLONASS corrections throughout the state. Not using the LoRa,
in fact not even using Bluetooth (I had planned to use LeFebure NTRIP and then mock
locations to my cell, then to Mobile Topographer but the Reachview application, with built in
NTRIP, and simple survey program, works better.) With CORS, I’m able to get a few
centimeters accuracy when measuring several government Geodetic monuments nearby.

But a few questions/concerns:

  1. Turning on Galileo satellites seems to crash the engine:
    I can’t reproduce this well, but if I have GPS, and Galileo, and Glonass, possibly when
    battery is a bit low, something bad happens. The number of satellites on the STATUS
    display falls to about 4-5 GPS satellites, and while green, it won’t calculate even a low
    quality position. But also the signal strength bars stay up about 5-6 seconds, then collapse
    down, then come back, then collapse, over and over again, like some internal error or
    electrical fault makes an internal error and reset. I spent about 4-5 hours yesterday, trying
    to figure it out, and when I plugged in my Reach RS+ to charge it, I noticed I got a few more
    satellites, and then when I turned off Galileo satellites, all the GPS satellites and Glonass
    satellites came back, and it started to generate positions again.
    Has anyone else had a problem like this? I may have had a position update rate too fast
    for so many satellites. But again, I haven’t been able to reproduce this well. Has anyone
    else seen this? I’m trying to reproduce it, and it may even only occur when I’m using
    correction data, as turning off corrections made it work.

  2. Reachview App on my Phone usually can’t find my Device:
    When my Reach RS+ is supplying it’s own hot-spot, my Android Reachview App seems to
    find it quite well, but when I have a local network that my RS+ joins, the Android Reachview
    App doesn’t seem to be able to find any devices. I tried turning on and off mobile data,
    but that doesn’t help. I’m using a Galaxy S9+ phone. I know my RS+ device is there, and
    if I can figure out the IP address, I can connect to it via a web browser.
    My main workaround is that I usually use my phone as a mobile hotspot, so it sets up a local
    network that the RS+ can attach to, then I can see all the IP addresses of devices attached
    to my hotspot, so figure out the RS+'s local IP address (192.168.0.XXX). Then I just open it
    in a web browser on my phone, and bypass the Application.

  3. Kinetic/Static switching:
    I have two needs: I need to survey existing locations, and get accurate position descriptions,
    and I have to track toward known locations, and place markers there.
    I had been using exclusively Kinetic RTK positioning to find position of markers, but it seems
    to take long occupy times, and due to trees, I often lose a FIX lock while waiting. Then I found
    that the STATIC RTK positioning really works great. I go to my location, turn on STATIC, and very
    quickly I get a high quality lock, even if signals aren’t perfect, and trees in area. Then I can do a
    collection in just a short occupy time, as the FIX is super stable. The problem comes when I go
    to my next location while in STATIC mode, it takes forever for the RS+ to let go of the old position
    fix, and realize I actually moved. So I have to switch back to Kinetic mode, go to new position, then
    switch back to STATIC. This this how we have to do it? Keep switching to Kinetic mode to let go
    of the old position, then switch back to STATIC once I’m ready to occupy the new location? Is there
    a better way to do this without switching back and forth?

  4. No Warranty?
    When my Reach RS+ was malfunctioning yesterday, and couldn’t get hardly any satellites, and not
    able to lock even a float position, I thought I had a bad device, and worried I was going to have to
    ship it off to Emlid in Hong Kong for a replacement. I figured that may cost me a ton even with
    economy shipping, and At best, I’m going to be without my device for a couple weeks. Then I wished
    I wouldn’t have bought direct from EMLID, and would have gotten from (a US/Canada
    based dealer) as I may have been able to return to them. But then I realized “there’s no warranty!”
    I looked over RobotShop’s web site, they say most items don’t have warranties, and you gotta contact
    manufacturer. But then I searched this entire FORUM and realized nobody knows what to do when
    these stop working. If the battery goes bad, maybe you can try to replace it yourself, otherwise you
    have to toss it, and buy another? It seems like there should at least be a 30-day replacement warranty
    in case a device goes dead right away. But I’m terrified, after spending half the day yesterday to get it
    to pick up satellites, that this thing is going to turn into a brick, no matter how much I baby it, and it’s
    trash. Yes, it’s cheaper than a LEICA or TOPCON, doesn’t mean I can afford for it to die, and just buy

Any thoughts or comments would be appreciated. I’m new to this, but so far can get high accuracy
positions with some work-arounds. I’m very happy with my device.

  • Thomas.
1 Like

I think I answered #3 myself. What I’m looking for is “stop and go” surveying, and I just found a forum
note talking about how the Reach RS+ does not have a “stop and go” survey mode. So I suspect
what I’m doing, switching to static when I stop on a point, and then switching to kinetic when I move on
to the next point, to break the lock, is the best option. I still don’t have a great way to track to and locate
a given location, but of course, we can always find a work-around.

Regarding #1. I’ve had my Reach RS+ on GPS, Galileo, and Glonass, with RTCM corrections for GPS and
Glonass, and it’s working well, without crashing like it did yesterday. So I’m still not sure what went wrong
yesterday, but my Reach RS+ became unusable for many hours. May never know why, but I’m worried
it could come back on an important far away project.


Don’t forget to provide your device info when requesting help. What version are you on?

Hi Thomas,

Welcome to our forum! :slightly_smiling_face:

Thanks for the report! We’re trying to fix this issue now. Currently, Reach reboot should help.

Do you have a possibility to test ReachView app with another Android device? Usually, there are no problems with resolving IP addresses with ReachView, so it would be great to figure out if the issue persists with another phone.

Trees definitely might influence the fix. The stable fix usually requires a good view of the sky, so it might be possible you need to wait longer to achieve fix under trees. If switching between kinematic and static works for you, you can use it.

Reach RS+ comes with the one-year warranty. In case you experience hardware issues, we’ll send you a replacement after a short troubleshooting procedure.

In regards to “Stop-and-go” method, we have plans on implementation, however, I hardly can provide you with ETA.


Oh, yea, sorry…
app version: 2.14.0-r0
'ReachView version: v2.14.0

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.