Got issue with simonk esc calibration , please help i am stuck here for long time

I build a X- type quadcopter with f450 frame, i am using flysky fs-i6, pixhawk, readytosky 2212 cw and ccw servos, 11.1v 25c 5400mah lipo, i follow all at once esc calibration but after calibration, if i remove power i need to do calibration again ( i am using PPM at this point) , after this issue i follow this link Got a serious issue with ESC calibration please help , where ozPup gave i solution to calibrate each esc with PWM mode and i calibrated all the esc manually but after calibration when i tried to start servo with PPM as ibus and sbus work in PPM, the servo is not turning on.

please help me.

Hi,
how do you know that you have to do the ESC calibration again?
Do the motors turn when the ESCs are connected to the receiver directly?
Simonk is not the firmware of choice anymore, blheli32 ESCs would be a better choice in the future.
Arducopter needs to be armed before any signals are send to the ESCs. It also performs a series of checks (GPS fix, etc.), which, if they fail, prevent arming. You can either arm with throttle down, yaw right stick movement and/or you can configure a switch on your transmitter to do it.

yes i am arming and still motor not running ,

But when i calibrate esc and until i do not disconnect the battery all servos are spinning ( servo working fine ) but if i disconnect the power i need to do calibration again.

You are talking about motors and servos. Does your copter have both?
Are you sure your copter is really armed? Disable arming checks in the full parameter list for bench testing. Enable the checks again for flying.
A parameter file of your setup and a dataflash log would also be helpful.

Thank you very much for quick response.
My apology, Motors and servos are the same.

one error is coming which is cricital : PreArm , this error is remaining before and after arming

This “prearm” message means your copter is not getting armed, because the “pre” arming checks found an issue, that could lead to an inability to fly safely or fly at all.
As I said, open the full parameter list in MissionPlanner and set the ARMING_CHECK parameter to 0.
Do this just for testing! Set it to 1 again before attempting the first flight!

by setting this parameter ARMING_CHECK = 0, pixhwak got blue led flashing.

when i try to arm, “mode not armable” error coming.

GPS count is 6-8

then i remove RTL from flight mode, and now i can arm the quad.

But after arming the quad all servos spin for nearly 10-12 seconds ( throttle is minimum) and then all servos stoped, now pixhwak get blue LED and i can’t able to spin servos.

now if i try to arm the quad again servos spin for 10-12 seconds (throttle is minimum) and then stop spinning.

The motors spinning after arming is the default setting. This way you have a clear signal that your copter is armed.
The copter will disarm 15sec after arming, if you do not raise the throttle. Another safety feature.

but after that if a raise the throttle the motor should spin right? but it isn’t .

Then there might be an issue with your RC setup/calibration.

thank you very much , the problem is fixed , but not there is another issue that even after giving full throttle quad is not lifting up.

I crossed check the motor position and also props, battery is fully charged. rating of battery is 11.1v 25C 5400mah 3s, 2212 920KV Brushless DC Motor, 1045 propeller , 30A esc and controller is pixwhak.

There are a lot of things that might be wrong:

Props to small or mounted upside down. The convex side must be facing up. top > ( < bottom
What prop size are you using?

ESC calibration not matching the actual input signal, so ESCs/motors never reach full throttle.

Lipo not able to provide enough current. (Unlikely with 5400mAh 25C)

Faulty (high ohm) power connection somewhere between the lipo and the ESCs.

And probably a few other things, I forgot…

Just saw your edit. 1045 props should be fine. What is the weight of the copter? Flightready with lipo and all?

copter weight is about 800 grams.