Got excited about Linux RTKLIB

Then I hit return…
./rtkpost_qt
./rtkpost_qt: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: version Qt_5' not found (required by ./rtkpost_qt) ./rtkpost_qt: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: versionQt_5.9’ not found (required by ./rtkpost_qt)
./rtkpost_qt: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version Qt_5' not found (required by ./rtkpost_qt) ./rtkpost_qt: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: versionQt_5’ not found (required by ./rtkpost_qt)

3 Likes

Just search your distro’s repository for the package that contains the missing files.

If you have Debian/Ubuntu/Mint or similar:

apt-get install libqt5gui5 libqt5core5a

If you didn’t compile it yourself, then it might be hard/impossible to get the correct files, as whoever did compile it should have included those file dependencies for you. Either that or you would need to install the same version of the same operating system as they had and you might get lucky and get it to run.

1 Like

sudo apt-get install libqt5gui5 libqt5core5a
Reading package lists… Done
Building dependency tree
Reading state information… Done
libqt5core5a is already the newest version (5.5.1+dfsg-16ubuntu7.5).
libqt5core5a set to manually installed.
libqt5gui5 is already the newest version (5.5.1+dfsg-16ubuntu7.5).
libqt5gui5 set to manually installed.
The following packages were automatically installed and are no longer required:
comerr-dev krb5-multidev libgeos-3.5.0 libgssrpc4 libkadm5clnt-mit9
libkadm5srv-mit9 libkdb5-8 libssl-dev libssl-doc linux-headers-4.4.0-31
linux-headers-4.4.0-31-generic linux-image-4.4.0-31-generic
linux-image-extra-4.4.0-31-generic
Use ‘sudo apt autoremove’ to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 70 not to upgrade.
Almost there, says it is installed, but no dice.

Hi Simon
Where did you get the linux version ?

It looks like your version 5.5 Qt5 packages are too old. I see version 5.9 is available in the testing and unstable repositories for Debian, but I don’t think you are on Debian.

I am boring and stable with Ubuntu 16.04 LTS.
So in about a year (or two) I will be able to use the Linux Emlid RTKLIB executables.

From my investigation the emlid RTKLIB build requires qt verison 5.4 which is to old for Ubuntu 16.04.

Sorry, my question was not clear : where dit you get the linux build of RTKLIB ?

It ‘appeared’ on the post processing documentation page. Link is still there…

Just some food for thought: You could always install qemu-system-x86 and virt-manager, and then install whatever bleeding edge operating system you want safely inside a virtual machine. …that is if you have the time to tinker around with it.

Okay, I have not investigated this myself, but in Simon’s error message above I see version 5.9 was required, so that is what I was going with. I’m happy to be corrected if that is not the case.

It’s typicall linux dependency mess. It would be best to build AppImage of the thing or something like that.

Ho yes I found it.
But I’ve the same problem than you with qt version.
I found sources here :


But I don’t know how to compile them, there isn’t any make file. The author claims to have used QT-Creator, but I never used it myself.
In the meantime I use the windows executables with wine, it works well.

Hi Simon,
Finally succeeded to compile the sources for Linux QT libs 5.5.1.
Could you try the binaries ?
They are here :

Regards

Pierre

1 Like

@zipang HUGE thanks for this.
Almost there… RTKpost_qc works, but RTKplot_qc calls a serial driver

./rtkplot_qt
./rtkplot_qt: error while loading shared libraries: libQt5SerialPort.so.5: cannot open shared object file: No such file or directory

Simon

Sorry guys,

This is my mess. We’ll try to fix this ASAP, I’ll update this post with instructions.

Can you try this one?

Kinda works,
I can get single GPS to produce results, but single GP+GLONASS doesn’t produce a solution.
(data works well on PC RTKLIB and delivers SINGLE or RTK GPS/GLONASS/QZSS/SBAS/GAL fix.
Although RTK plot opens when directly opened, it does not open from within rtkpost.

Reason I was excited is that my Linux box has the better graphics card and memory and processor. I currently run rtklib in a vm using windows 10, but not getting screen refresh that the linux box does. this makes a huge difference when rtkplot-ting a large obs file (150mb) to look at snr.

Ok, so the dependency issue is sorted out, which is a step forward. May the missing solution be due to different settings? Mainly, base antenna position. Maybe it’s an issue with RTKPLOT configuration? Please share the logs, we’ll take a look.

This isn’t the final version yet, I’ll see what we can do regarding the inactive rtkplot.

Any news regarding this? It would be wonderful if this worked as it should. Considering the open source foundation of it all i feel silly running it in a Windows VM. :slight_smile: