Getting Started with Reach RTK

Hi all,

Thi is the first time I am here and first time using RTK. The new Reach kit has arrived and we are looking at getting the start. It’s connected to a laptop running Windows 10 and Chrome browser. However, we couldn’t get through Reachview updater. Here is the screenshot.

We tried to switch to my home and work wifi networks, then the screen is:

The windows network diagnosis says the device is not responding;

The LED remains solid green color.

Could someone please help us out of this? Thank you very much in advance.

Green LED means REACH is working. Did you follow the instructions for setting up the REACH?
https://docs.emlid.com/

The 1st time you power up REACH, it powers up with its own wifi hotspot. You need to use (your cellphone, wireless laptop, etc.) to join that hotspot, change its wifi information to your own wifi network, then access the REACH again from your own network. You need to use the FING program (free from internet) to find the REACH’s IP address (assigned to it by your own wireless router) and use that IP address in your Chrome browser (best to use a new Incognito window in Chrome). Also make sure your computer has Internet access or REACH will not be able to get its update.

2 Likes

Thank you very much. However the problem still continues. I have followed the setting up steps in the instructions for the Reach and made sure my laptop can access wifi.

Also, I gave my wifi information under wifi section in the reachview updater. Still wondering what went wrong.

I recommend turning off REACH, your wireless router, and your laptop, then turn on REACH. REACH will not see your router (because it is off) and will start its own hotspot. Now, turn on your laptop and goto wifi section and look for REACH’s hotspot and connect to it. Run the FING program (on your laptop) to find the IP addresses for the REACH’s hotspot and your laptop. open your Chrome web browser and enter the REACH’s hotspot IP address, hit enter. You should see the ReachView front-end. turn on your wireless router, wait a few minutes, then type your wireless router’s name and password (if any), and encryption type (if any) into the ReachView (follow the menus according the instructions). The REACH module will try to connect to your wireless router now. Goto wifi section of your laptop and connect to your wireless router. run the FING program again on your laptop to find the IP address of the REACH and enter it to your Chrome web browser. You should see the ReachView front-end. This time, REACH has access to internet because it is connected to your wireless router and should be able to update itself. However, I believe, REACH checks for update during power up, so turn its power off and turn it back on (also run the FING program again to make sure it still has the same IP address).

1 Like

Reach will change its address after connecting to your network. Please perform a FING scan as per the docs and use that new address to access ReachView.

1 Like

Hi, It still doesn’t connect to my wifi network. When I tried to load Reach ip address the page says the site can’t be reached on chrome. Also, I tried Microsoft edge browser too. it says you are not connected.

Reach do either create hotspot or connect to wifi. Can you tell what its done now?
If no hotspot is found of reach, it is connected to the wifi you have assigned it to.If so, your problem lays within the wifi device. It could be a setting or a hardware problem.
Also, fing cant find reach if the device you a connected and use fing on in not on the same subnet as reach, verfy this.

Thank you for the reply. The LED is solid green color. I think that is indicating a hotspot is started.
Yes. When I run Fing, it does not shows Murata Manufacturing.

I can only go upto this step.

After I hit Connect button, I get the screen as,

It says switch to my WiFi network. when I switched my connection to my network, it remains same. nothing happens. When I connected to my WiFi, the Reach loss connection with my laptop (Because we can connect to only one WiFi network at a time). and remains with Green LED.

How can I get both Reach and my WiFi router connected at the same time?

Once you hit “connect” in reachview, reach shuts down hotspot and connect to your wifi, your laptop lose connection and you need to reconnect it to your local wifi, which reach is also connected to. BUT, reach dont use 192.168.42.1 (just in hotspot mode).
So you need fint out what address reach use, and thats why we use FING app on your phone (which also, hopefully is connected to the same local wifi).
You should have YES to all questions below:

-Phone with fing app connected to wifi
-laptop connected to wifi
-wifi has DHCP enabled
-Wifi does not block connection from reach

If not, try different wifi device, or your phone as hotspot.

Hi, Thank you very much.
I don’t see an IP address for Reach using Fing. I also tried Zenmap and I can’t see Reach in there either.

I can say YES to first three questions, but how can I find out whether Wifi does not block connection from Reach?

I tried both laptop and phone, but it gives the same output.

Does reach create hotspot if you reboot reach after you hit connect?

Could you elaborate this part?
What type of phone?
What specs for the wifi device

Yes. It creates the hotspot. I tried with a Blackberry and a Windows 10 phones. Same output. Reach does not connecting to my wifi. We have FibreOP 260 R3000 wifi modem.

You have to excuse me here. Just to be sure.
But you did start another hotspot/wifi/access point for reach to connect to?and that failed too ?

Yes.

And it happen to both devices?
Would suggest to reflash but its highly unlikely that both have the same error

Yes. The both have same error. Didn’t try reflashing yet

What reachview version is this and are both the same?
And could you please post screenshot of fing when you search for reach?

Reach should an ip address e.g 192.168.1.xxx or 192.168.2.xxx