Getting Fix level corrections from NTRIP takes 10-15+ minutes

Whenever I try to get Fix level corrections from my local NTRIP network it takes 10-15+ minutes to go from Float to Fix using my RS2+. I don’t think it should take this long. The baseline is 20km. I am able get Float level corrections immediately. Is it normal to take 10-15+ minutes to get Fix level corrections from NTRIP? Or am I doing something wrong?

Hey Eric,

Depending on your environment and/or satellite geometry, it can take that long. Float just means the rover is talking to the base. It doesn’t necessarily mean that your are almost at FIX. Do you record logs of your observations. You can drop the log into Emlid Studio to quickly see what the receiver was seeing.

Ok, thanks.

Data availability also greatly affects the success of NTRIP. In my experience it is more likely to be the problem than interference of satellite conditions. Even if you show a 10mbps connection in the field there can be a lot of latency (slow pings and high jitter) that kills the interval of corrections and will essentially float you until it is consistently less than 2 seconds.

1 Like

Hi Eric,

If Reach RS2+ is placed in a clear sky view, it should get FIX in seconds. I think you need to check the NTRIP provider configuration.

Have you tried using different mountpoints? Some mountpoints may not transmit all satellite observations, so it takes longer to receive the FIX solution.

If this service is VRS or requires a rover’s position, you also need to enable the switch Send receiver’s position to the provider as shown below:


Here’s the speedtest I use for the field.

Ping (latency) - below 80ms
Jitter - below 30ms

If either of these are broken maintaining a solid fix can be a problem.


Hello @kirill.pavlyuchuk , I believe my NTRIP profile is set up with all the correct information according to my NTRIP provider. I simply selected the closest mountpoint, which is about 19-20km away. I will try a few different ones tomorrow. And yes, the “send receiver’s position” was activated.

If it continues to take 10-15 minutes or more to get Fix level corrections I will contact my NTRIP provider to see if there’s anything else I can do. Thank You…

1 Like

Have you tried multiple sources of data in the field? I had to get a router that supported dual SIM and had service with both AT&T and Verizon before I could comfortably navigate my entire work area. Even with that I still hit projects where local LoRa for terrestrial and local NTRIP on the drone were the only options.

1 Like

@michaelL I am going to look into getting a jetpack for the field and also possibly sim cards for my Emlid receivers. Thank You for the response and advice!

1 Like

So I tried the next closest mount point and was able to get Fix level corrections within a couple of minutes. I discovered the one that is 19km away only has GPS, but the one that’s 31km away has both GPS & GLONASS, so maybe that is the difference.

1 Like

That could definitely make a difference. Glad you got it going.

Hi Eric,

Glad to hear that it did that trick!

Given the choice between a GPS base 19 km away and a GPS/Glonass base 31 km away, I’d prefer the second. Although, the best option is still a CORS station that tracks all satellite constellations.

1 Like

…and VRS is even better if that’s an option.

1 Like