Geographiclib exception

Image: Latest Emlid Raspian Image (don’t know exactly what version) running on a Navio2 + raspi 3board
ArduPilot Version: ArduRover 3.3.0

When setting up the Navio 2, I followed the steps for setup, eventually reaching the point where I’m starting to run mavros. This is in tmux, and the led was already blinking from running ardurover. As per the instructions, I entered:
rosrun mavros mavros_node

When I hit enter, I got an error message saying:

GeographicLib exception: File not readable /usr/share/GeographicLib/geoids/egm96-5.pgm | Run script in order to install Geoid Model dataset!

Which is pretty weird considering that I’ve already run the script. Either way, I thought I’d rerun the script, so i typed:

sudo /opt/ros/kinetic/lib/mavros/


sudo systemctl daemon-reload

When I tried to run mavros again, I got the same error.

Did I miss something? Thanks.

I’m new to this whole raspi programming thing please play nice

Hey there,

As I understood, you’ve tried to follow this guide.

In the second string, you need to specify the IP and the port of the computer with GCS. As I can see, you’ve made some typos: firstly, there should be a colon after the IP, and, secondly, according to the guide, you should use 14550 port of the computer. So, the second string must look like this:

Solved: I reflashed the pi and everything started working properly

Sorry, those were some typos I made when hastily copying the code into the dialog box, thanks for your help.

1 Like