Galileo GNSS Navio2

I connected Navio2 to u-center to visualize Galileo sats, but I can’t. I was wondering if an updated is need it or how to solve this issue.
Thanks in advance.

source: (Emlid website)

GNSS receiver

Tracks GPS, GLONASS, Beidou, Galileo and SBAS satellites. External antenna with MCX connector

Hello,

You have to connect via SSH to your Navio2, stop ardupilot with emlidtool

Capture d’écran 2020-09-08 à 19.51.10
then run ublox-spi-to-tcp utility…

When done, run u-center (latest is 20.06.01), open Configuration view and go to MSG menu.

Set it to 01-35 NAV-SAT, and check SPI On

In the GNSS config menu, select Galileo and GLONASS or GPS (M8N can only run 2 system at 5hz)

Screen capture is at 1Hz refresh rate

Save the configuration when happy and reboot to restart ardupilot.

1 Like

Thanks @mlebret,

I try to follow your steps, but I can’t save (send/pull) the configuration.
Also, when I enabled Galileo and Send, automatically disabled again…

When I did it, I received this message during transferring configuration from GNSS to file,

  failed due to timeout!
Polling: MON-VER -  B5 62 0A 04 00 00 0E 34 ...
... timeout occurred without receiving an answer. Retrying...!
Polling: MON-VER -  B5 62 0A 04 00 00 0E 34 ...
... failed due to timeout!
Polling: CFG-ANT -  B5 62 06 13 00 00 19 51 ...
... timeout occurred without receiving an answer. Retrying...!
Polling: CFG-ANT -  B5 62 06 13 00 00 19 51 ...
... failed due to timeout!
Polling: CFG-DAT -  B5 62 06 06 00 00 0C 2A ....

Hi Andres,

Mark has described the procedure of connecting u-center correctly. Although, Navio2 does not support the signal reception of Galileo constellation. That is why your configuration has been reverting back.

Hi @mikhail.goryachev
Why Navio2 specs at Emlid website shows Galileo GNSS is supported?
Please, could you explain more about this?
Thanks

Hi Andres,

Sorry, my bad. Mixed it up a bit. Navio2 works with NEO-M8N chip which supports Galileo.

I will check what could have caused this error for u-center while connecting Navio2 and will get back to you.

1 Like

Thanks for your reply @mikhail.goryachev. I’ll wait for some news.

When trying settings on my Navio2 GPS, enabling Galileo and disabling Glonass, the “Send” command was doing nothing (like on your unit).

I had to reset the GPS default settings to have the “Send” command working. Before doing the reset take note of the GPS settings in order to restore them manually if needed.