FYI - rtkpost GPX bug & workaround

Hello all,

This might be useful to others.

I recently produced 15 GPX files using rtkpost version to geocode images using exiftool. Exiftool had success geocoding the images associated with 14 GPX files, but 1 GPX file caused a problem: exiftool gave error message “Warning: Second ‘60’ out of range 0…59 in File:Geotag (ValueConvInv)” and encoded none of the 200 targeted images.

The source of the error:
for one of the ‘times’, rtkpost wrote this in the GPX file it produced:
instead of
The times before and after were written correctly, one second before and one second after (23:29:59.00Z and 23:30:01.00Z).

The same ‘time’ (with the same error) was encoded twice in the GPX file, inside the ‘wpt’ and ‘trkpt’ tags.

Workaround: manually correcting the time where the error appeared in the GPX file allowed exiftool to encode the targeted images.

Not certain where in the PPK chain the bug comes from.


Fred Jean

1 Like

Hi Fred,

Do you use the RTKPOST version from our docs?

Can you please send us your logs so we could try to reproduce this issue?

Hello gleb.gira,

Yes, I’m using Emlid’s RTKPOST.

Please provide email address so I can send logs privately - thanks.


Hi @fredojean,

Thank you for sharing these logs. I tried to reproduce this issue with other data but to no avail. I’m afraid we can’t investigate this bug without more information.

Have you managed to reproduce this issue with other logs?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.