Frysky telemetry

Hello all,

I have a raspberry3 with navio2 running ardupilot.
My Receiver is a x4r from frysky, capable of transmitting telemetry Data to my Transmitter.
I’ve read a lot about smart Port Cables and Converter to uart. But i’m still confused.
All desriptions in ardupilot Wiki refer to a pixhawk flightcomputer.
Do you have any suggestions which cable or converter i need, to connect my Receiver to my raspberry / navio2.

My Receiver was shipped with a cable for the smartport (4 pins), the cable has a 3 pin connector on the other side (one pin isn’t connected). Can i use this cable? And where to plug on my flightcomputer?

Thanks and Greetings

Hello.

From ArduPilot docs you should connect SmartPort to Navio2’s UART: GND - GND, TX and RX - SmartPort’s data pin.
Run ardupilot with -C /dev/ttyAMA0, set SERIAL1_PROTOCOL to 4 (Standard SmartPort telemetry) in GCS and reboot.

I don’t have Transmitter which support telemetry input, so I can’t test this.

Am i right with my assumption:
A simple cable from s Port to uart will Not Work.
I do have to use a ttl to uart converter.

Not ttl to uart, but RS232 to ttl. And you will have to add a diode to the TX/RX pins to mux the signal onto one pin for SmartPort. A FrSky FUL-1 works or a cheap MAX232 converter on a pcb.

maybe this one can help you.

http://www.craftandtheoryllc.com/store/ct-telemetry-cable-for-frsky-radios/

This sorts the hardware part

and this the software part

I’m using this on a Navio2

Hey Luis,
thank you for the Links.
After ordering the parts and some soldering, I testd the telemetry. But it doesn’t work.
The I’ve conntected the converter cable between smartport of my receiver and uart port on Navio2

I’ve configured ardupilot like the following:

/etc/default/arducopter:

TELEM1="-A udp:127.0.0.1:14550"
TELEM2="-A udp:192.168.2.122:14550"
TELEM3="-A udp:192.168.2.147:14550"
TELEM4="-A udp:192.168.43.28:14550"
TELEM5="-A udp:192.168.43.1:14550"
TELEM6="-A udp:10.8.0.1:14550"
TELEM7="-C /dev/ttyAMA0"

# Options to pass to ArduPilot
ARDUPILOT_OPTS="$TELEM7 $TELEM1"

SERIAL in Parameters

SERIAL1_BAUD 57600
SERIAL1_PROTOCOL FrySky Sport Passthrough (OpenTx)

I copied the yaapu script onto my Taransi Qx7 and added it to Telemetry Page. But it only shoes the message “Not Telemetry”

There’s one thing i’m not sure about. I added the diode between tx and rx on the rs232 side of the chip (I think, this is what the picture in the Thread shows).

Am I missing some configuration in the Parameters or should i rethink the soldering part. Where should I start searching for the error?

Thanks and Greetings
Jakob

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.