Flight Log Location on Navio2 Buster

Hello there,

I am having a hard time locating the flight logs on the Buster image on the Navio2 for my quadcopter. I have checked under the /var/APM/logs, or /var/log/APM and cannot find the files (No such APM directory even exists).

I manually upgraded the firmware of the copter to ArduCopter-4.0.3, so not sure if this affects how the logging is performed. Additionally, when I connect with MissionPlanner, I can see a list of the log files for the various flights image

but cannot download them into MP, receiving error “Error in log Timeout on read - GetLog” after a few seconds. This is why I am attempting to locate the files so I can sftp them to my computer.

Additionally, I ran from the root directory
find ./ -name "*.bin"
find ./ -name "*.log"

which didn’t provide clues to where the logs may be.

Could I borrow someone’s wisdom on this?

Hi @caleb,

Have you tried collecting the logs via the USB?

According to the Ardupilot forum, the logs are hard to download over the Wi-Fi network.

Hi Artem!

I ended up just downloading the log files locally on the RPi with mavproxy, then just scp’ing to my mission planner computer.


1 Like


Logs are in


With the wifi connection, I have no problems to download logs. No way to do it with a telemetry module (UART).

Hi @caleb and Marc,

@caleb, thank you for reporting. I’m glad it works this way.

@mlebret, thank you for the supposed approach. It should work just fine too.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.