Fix position with smart net (Leica) corrections

I managed to receive corrections from Leica smart net and I achieved a fix position,
My issue is that when I move the antenna to my next point it loosing the fix position and the AR ratio is dropped below 2 for some time until I achieve a fix position again.
I used to work with Leica smart rover antenna, and didn’t have that issue.
Any recommendation, settings maybe?
Thanks in advance


Please post the system report from your Reach RS rover (73.0 KB)

please check the attached system full report.

I think the problem might not necessarily be connected to you moving the rover. I see that you have GLONASS AR set to on, that might just be the reason. More details here.

Also, any reason the connection would drop out when moving the rover? You can check the age of differential value in the status tab, it must not grow over 2 or 3 seconds.

Thanks again for your support
I done all that and yes now I have a fix position with AR ratio more than 100!!!
But now my field controller running magnet is not storing the position if the AR ratio is greater than 3 and fixed. I am sending you some photos
Please check

It’s ok with Leica corrections

I have sort it out

I suspect it has to do something with the communication between Emlid and Topcon magnet software

Now it has more than 100 of AR ratio and when I moved to next point it takes 2-3 seconds to find fix again !!! This is great!!!

Any update regarding the TopNET corrections??


1 Like

Could you post some more screen shots showing your Topcon Magnet settings? It would be great reference material.
Does it show “Fix” or “DGPS” in Magnet software when you save a point?
Is it correct that you are doing your corrections on reach RS and send nmea string to Topcon data collector?

Yes I will in first opportunity
Now my other issue is when I connect my Reach with the serial port of my GPR monitor
I used a smart antenna in past and I didn’t have any problem.
Now I connect the serial port setting NMEA output and baud rate 19,200 but there are no cordinates coming through

First, confirm that you have coordinates displayed and updating live on the ReachView status page.

I see that you have checksum validation off, which is one thing, but are there any other serial port settings, such as handshaking, DTR/DSR, CTS/RTS, or flow control? If so, turn them off too.

Try a much slower baud rate, such as 4800 and see if anything changes.

If none of these works, then I can think of two options:

  • there could be some modification that needs to be made to the cable wiring, or
  • your GPR is not able to parse the NMEA sentences that Reach is sending out.

Do you have a manual for the GPR that shows how to properly connect to the RS232 port?

It appears that this is all you can try then:

If there are not handshaking settings in your GPR, then I doubt it requires all those signals shown the pic you provided. I am guessing that is a generic pic of an RS232 port and therefore it is not helpful in determining the proper wiring. Usually only 3 wires are required: GND, TX, RX

It could be that your GPR software is not parsing the NMEA sentences properly. Maybe you need to send a screen’s worth of NMEA sentences from Reach RS over to your GPR vendor and ask why it is not parsing them.

Alternatively, if you provided some NMEA sentences from your Leica smart rover, then we could see what the differences might be.


Hello and thanks for your reply
The wiring diagram picture is from my GPR manufacturer (Mala geoscience) after I asked them for it.
How can I provide you with my Leica corrections NMEA sentences?

Maybe ask your GPR manufacturer which of the signals depicted are required for communication. Surely all of those 9 pins are not needed. As I said Reach just uses 3. If they need more than 3 pins connected, then you probably just need to wire up a connector with jumpers between a couple of pins.

Just plug your Leica into an RS232 (serial) port on a computer or laptop. Then capture the data in a terminal program like Hyperterminal / Minicom or similar. You could do it from the command line as well. Make sure the antenna is outside while capturing data though.


Uploading… Uploading… Uploading…
I just follow the how to connect emlid with magnet online guide
My reach antenna is indoors at the moment next to a window and still i can get a fixed position.

1 Like

Even though you quoted my comment about Hyperterminal, I’m going to assume the pictures you just posted are for @Brent_W. <-- ping

1 Like

oopps yes you are right!


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.