FIX drifts to FLOAT when raising Update Rate Frequency

Hi Igor,

Thank you for improving the GPS quality for us.

I am sending my corrections from a Reach Base using TCP, to a 4G Wifi hotspot, that has a static IP.

I then receive the corrections on my Reach Rover using the same setup with a different 4G WiFi hotspot.

I have found that I have to set the GPS base as follows;

GPS set to 0.5Hz
BeiDou set to 0.1Hz
ARP station to 0.1Hz

With only these settings ON the Reach Base, I can obtain a FIX solution.

This takes awhile to achieve FIX and to be stable though. Once it does sort itself out, it is not too bad at maintaining a FIX solution.

If I up the frequency rates of these, it drifts in and out of FIX mode, but it is mostly in FLOAT mode only.

I need it to maintain FIX mode as I am using Reach to display to the user real time information.

My Questions
Now that you have added the AR and improved a problem with BeiDou AR. Would I get a better result if I enable AR mode on my Reach Rover in the RTK settings?

In the Rover, do I simply turn ON Glonass AR mode for this to work?

Is there something I need to do on the Base to enable AR mode as I can not see this setting?

Is there any other suggestions you could offer me that would improve the Base to Rover on the fly setup as used be myself, so as to help me maintain a FIX solution on the fly, as I have tried many things to do this without success?



Hi Cameron,

This is interesting. Could you please share system reports and logs from base and rover where floating solution can be observed?

Hi, Tatiana,

This is the settings I am running in my Reach Base. I hope this can help you.

Please remember I am running this vai a 4G wifi hotspot using the TCP connection

Simple system report
app version: 2.13.0-dev-r0
'wifi_status, interface: wlan0':
- Client state
- IP address:
  mac address: 78:4b:87:a9:45:2f
  ssid: dcsa_Drill
base mode:
  base coordinates:
    accumulation: '5'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    - '-16.42675496'
    - '136.09784383'
    - '128.957'
    format: llh
    mode: manual
    enabled: true
    format: rtcm3
    path: tcpsvr://:9009#rtcm3
    type: tcpsvr
  rtcm3 messages:
      enabled: true
      frequency: '1'
      enabled: true
      frequency: '0.1'
      enabled: true
      frequency: '0.5'
      enabled: false
      frequency: '1'
      enabled: false
      frequency: '1'
  discoverable: false
  enabled: true
  pin: '***'
  duty cycle: 20
  enable: false
  period: 2
  polarity: true
correction input:
    enabled: true
    format: rtcm3
    path: localhost:9009
    send position to base: 'off'
    type: tcpcli
    enabled: false
    format: rtcm3
    type: tcpcli
    format: RTCM3
    started: false
    version: null
    format: RTCM3
    started: false
    version: null
  interval: 24
  overwrite: true
    format: UBX
    started: false
    version: null
    format: NMEA
    started: false
    version: null
position output:
    enabled: true
    format: nmea
    path: :9005
    type: tcpsvr
    enabled: false
    format: nmea
    path: :2013
    type: tcpsvr
    enabled: true
    format: llh
    path: :2014
    type: tcpsvr
    enabled: true
    format: llh
    path: :2015
    type: tcpsvr
rtk settings:
  elevation mask angle: '1'
  glonass ar mode: 'off'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: true
    galileo: false
    glonass: false
    gps: true
    qzs: true
    qzss: false
    sbas: false
  snr mask: '30'
  update rate: '5'


Would be also useful to see system report from your rover.

Have you tried post-processing the data? Could you share your logs?


Hi Dmitry,

I only use my base and rovers to display real time data.

As a result I have never had the need to post process so sorry no I can’t give you this information.

I will post the rover config for you as soon as I can.

It is basically the same as the Base with GPS and BeiDou at 5Hz


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.