First setup - can't access reach via HTTP after upgrade to 2.3

I just got my reach rtk kit. When I first powered the base, it would start a hotspot wireless and I could connect to the ip-address with a browser. It was version 1.3, so I decided to upgrade to 2.3.
Upgrade presented no errors, it worked fine. I configured ssh and a my home wifi for it to connect to.
Reach connects to the local wifi, but I just can’t access it’s configuration page through http. I can log in with SSH no problem.
The ip address it got through dhcp responds to ping, and a portscan revealed ports 110, 119, 143, 563, 993 and 995 to be open.
The LED is light constantly - with a magenta light.
I even tried the usb ethernet setup, and can connect with SSH to
I haven’t tested so much with the air unit, but it seems to be the same.
The base has been sitting outside for a few hours.

Hi, What browser do you use? and does it have incongnito mode?
Works http:reach.address:5000 ?
And make sure you have god wifi link/coverage to reach

If not, a reflash might be necessary

I am using chrome, but I was not using incognito mode. Port 5000 isn’t responding.
First I had reach base sitting outside - about 15 meters away (through a wall). As I mentioned - I could happily SSH to it, so it must have been on the house wifi.
I actually reflashed it once, but I can try again :slight_smile:
I just thought it was odd that I can get to it by SSH, but not by HTTP. Is there a way to check if all services have started (from console)?
Will reflashing reset the known wifi networks? I tried turning off the wifi network I joined it to - but it did not creat it’s own hotspot.

Flashing reach would wipe wifi credentials yes.
Few times i have faced similar issues, and a second flash have fixed it for me. Might give it a shot.

Norsk ja :).
I just reflashed it (3rd or 4th time). This time I did not configure SSH or WIFI. It’s been sitting outside in open air for about 20 minutes now, and I see no hotspot wlan. This laptop is set up with a address on the USB adapter, and I could ping after flashing, before I put it outside.
If I connect to USB again and configure SSH/WIFI, I’m pretty sure it will be available on my house wifi again through SSH.
It definitely resets the wifi, but I’m back to my original problem it seems - that it doesn’t start the hotspot wifi so I can configure it.

Hmm, not sure about this but could it be stuck on timesync somehow, even thoug it sits outside.
Which brings me to the next question and assume you hooked up the antenne to reach and have valid groundplate under?
Are you still able to connect to reach hotspot to verfy signals stated above?

I have hooked up the anntenna yes, and i only had it powered without antenna indoors to flash it.
I don’t have a ground plane yet. I thought it would get some signal withouth it but that it’s required to get the desired precision.
I have not been able to connect to it with wifi since I upgraded to firmware 2.3. It had firmware 1.3 when I got it.

I can place it on the roof of my car to test with a proper ground plane, but I fear the problem is elsewhere.
I have only tested briefly with the rover after it was upgraded. I’m going to reflash that too to see if it behaves the same way.

Thanks for your time!

So it would not create its own hotspot either? after you turned off your wifi and rebooted reach.
Should work without groundplate, its just so any obvious obstacles is removed, just to be sure

No, I think that’s the main issue since upgrading to fw2.3 - that it doesn’t create the hotspot.
I just noticed another thing that happens with both base and rover. When I connected them to the laptop with fw1.3, an extra drive popped up.
After upgrading to fw2.3, I now get a popup saying I need to format the drive to use it.

I just had a look at both units, and shortly after powering on (battery with usb connector or adapter to mains behaves the same way) - the led goes blue, and then 2 or 3 red flashes. To me it almost seems like the LED is part blue, part red.
Is there any way I can check the firmware version on the console of the edison? Anything else I can kickstart, kill off or do from the console?
I have no idea where to proceed from here. I fear I’m making a stupid rookie mistake.

One thing that have me puzzled, is that I after I run the intel_edison_setup_win_v2016.2.007.exe file and the setup is completed, I don’t have an edison setup tool installed on my computer. But that’s maybe the way it is supposed to be?
I start this exe, It checks firmware version, ssh config, and comes up saying usb drivers installed, firmware version installed 201606061707. Matches latest from SSH not enabled, and wifi not online.
I proceed, and point the flash tool to the directory where I have the fw2.3 and on it goes.

Reachview version 2.1.3 you got and upgraded to 2.3.0, right?
Have a kit my self, gonna try later to see if i find something

Hmm, it did say 1.3 - no mention of 2.1.3 - and it seemed quite old. I think these units were purchased by their first owner in March last year. He didn’t do much more than testing. I tested them briefly and saw version 1.3 in the gui before I decided to upgrade.

You must have got an old v0.1.3 reachview.
But following this doc should bring you up to speed. Its the one you used, right?

I tried to flash the rover unit again and something changed! LED ended up green,and the hotspot showed up.
I tried connnecting to it with password emlidreach, but it wouldn’t accept it. Trying to upgrade the base too while the luck is with me :slight_smile:

One more thing, You may have to replug Reach (or have reach unplugged to you get to this point) usb if you get to this point (screenshot in link below)

Looks like I have pulled through. I did one step differently this time. When opening the file to flash, I opened the FlashEdison.json file. The previous times i just pointed it to the directory where the json file was located.
Not sure if that’s enough to throw the entire upgrade process off? It was very clear in the previous attempts that it did do stuff, and was taking it’s time too.


Hehe, troubleshooting these kind of errors are never easy.


Hey Tore, I am trying to update my Reach RTK. I have never used it and finally got it out of the box to update it. When I first powered it up and connected via wifi, it prompted to to enter wifi info and update. It was on a very old version and it actually updated twice. First time to newer version, and second time to most recent version.

However, it will only go to the TEST>WIFI>Time Sync screen. The Time Sync is not getting a check mark on Time Sync. I then re-flashed it using the guide you linked above and it flashed successfully. However, I am still having the same problem. How do I fix this?

Disregard. It is working :slight_smile:

1 Like