Firmware Upgrade v 29

Hi, there. I have installed the upgrade from version 2.8 to 2.9 and now my Emlid Reach M2 does not work anymore. When I connect it to the power supply and the baterry, only amber light no other lights are lit. I can also recognize the reach:F6:9D on my wifi connections and I can connect to it, however when I try to connect Emilid app it simply does not work anymore.

Any solutions for me?

1 Like

We experienced some similar issues and rolled back to 28.4 and it has been good. My posts on troubles starts about here.


Thanks Michael. Much appreciated! I tried to roll back to 2.8.4 however it didn’t work for me. The computer is not recognising my reach M2!?

Now I am stuck with the version that doesn’t work and now I can’t even roll back! Please help anyone!

As in the computer can’t see the Reach Hotspot? Or you can’t see it when it is connected to the same network as your computer/device? I did do a factory reset once I got 28.4 back on… Make sure to screen shot any important settings.

How is it possible to roll back the software installation?
I have never encountered such an option

Hi, Adrian.

Yes, you can simply flash your Emlid device with whatever version you want.

1 Like

Thanks Michael again! You are a legend! I did actually manage to flash my M2 back to 28.4 version. It did not work at first because I used a charging cable not the data cable! Silly me. Yes, and the device is now working just fine with the 28.4 version. DO NOT INSTALL 29 Beta as yet!


Hi @zorzterzic,

Thanks for letting us know about the issue you encountered! Can you please share the serial number of your device with me? You can find it at the bottom of the unit, under the bar code.

I just want to mention that if the unit lights up the red LED only, it usually means there is not enough power for it. So it’s better to check the cables and the power supplies first. If the issues persist, contact us at

Our 29 beta 1 is indeed a beta version that you can update for new features. It can contain some bugs that’s why it’s better to avoid using it for important fieldwork.

Hi, Polina. Thanks for the response. I have resolved the issue by retracting back to v 28.4 and the device is now working just fine.
I tried at least three different power supplies with it and it did not change. Then I just reflushed it with the v 28.4 and it all comes good. Yes, I agree the v 29 beta 1 I did install on my own risk so yes, it was my fault.

@zorzterzic, glad that everything’s working for you now! Just to check out what may cause issues on the latest beta, we need to analyze any error data. That’s why I thought that maybe we will have something in our system from your unit to check out.

Ok, Polina. The serial # 824361BB7E5EF69D2010

Hi, Polina. The FCC I D: ZQ6-AP6212A

Hi @zorzterzic,

Thanks a lot! Meanwhile, we have pushed Reach Firmware 29 Beta 2 with a few additional features and fixes :slight_smile:

I’ll be sure to tell you about the next stable release, though, so you can update without any doubts!

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.