Firmware Reflasher Windows Software not working

just tried to install the windows firmware reflasher.
In windows 10, this happens:

I.e. nothing---- just freezes. Reboot did not change a thing—

Installed fine on mine. You might check your antivirus software. More often than not, they are the culprit for software not installing.

I dont have antivirus software.
And as you see, the window is corrupted.

I made it work on another WIN10 computer…
Unfortunately flashing 2.22.4 failed…

I flashed a M2. It took many tries and I used about every USB cable I own till I found one that worked properly. It would initiate, start flashing and quit anywhere from 0% to 27%

It is a pain in the back

1 Like

Ok so:
I was able to revert back to 2.22.4 from Dev version by going through:

  1. Flashing 2.22.4 on the device
  2. During flashing (either 2.22.5 or 2.22.4 the flashing software said: “flashing failed”
  3. Start RS2 and connect to Reachview
  4. Connect to Hotspot and cut internet connection in the process of “upgrading” to current firmware (I disconnected when the upgrading step was enabled, but apparently you can also cut internet while upgrading to the same effect)
  5. Now youcan skip upgrading

All in all, I have to say that the firmware flashing tool does not work properly in on either mac or win10 (at least gives an error). --> Please remedy Emlid team! This is not what I would call a pleasant user experience --> 2 hours lost because of this.

Hi @kasanmascheff,

We’ve updated our Flasher to a new version. The download links are available in this article in our docs. It should resolve the flashing issues you’ve experienced.

Regarding the install window of the Flasher, could you please specify which screen resolution and scaling settings were you using?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.