Firmware flash tool does not find reach module

Thanks - I tried both with and without the edison drivers, it didn’t make a difference.

More reading. Only way I was successful to get flashed to firmware 26. USB-to-PC still does not work though.

Hi @Charlie_Robinson, I have just been through the process of flashing my old reach modules to firmware 26 on a win10 machine. To get USB-to-PC connection I needed to disable driver signatures and then install EdisonDriverSetup1.2.1 as per this thread Flashing Reach RS - Win10
The flashing tool then found the module and completed the update without issue.

HI Ewen, thanks very much. Unfortunately this doesn’t seem to work in my case. I sucessfully used the workaround to install the Edison drivers but the flash tool still doesn’t find the Reach module.

Glad it worked for you. Yes, it is quite difficult, but only way I could find to do it.

Maybe try a different USB port? Or if laptop, an external powered USB port? Or another PC?

Hi Charlie, Sorry to hear you have not yet had success.
A couple more observations from my experience, note this is my first time using Reach modules so apologies if I am stating the obvious;

  1. Installing Edisondrivers - Disabling driver signatures is a must per the previous post, I also then ran the setup in administrator mode to ensure the software had full access. during this setup you will get some warnings as windows detects the signature issues.
    If the install is successful, once you reboot the p.c and plug the reach module into a usb port, the device will be recognised and shown as an Edison device in device manager, if you still have RNDIS with exclamation mark then Edison drivers has not installed correctly.

2)I found that the flashtool must be started and be looking for a reach module before the module is plugged into the usb port, otherwise it will not be detected.

1 Like

That would be great, but if the Reach Flash Tool cannot detect the device, then the problem persists. : /

Hi Charlie,

Would it be possible to share the screenshot of the Ports section of the Device Manager as well?

We’re currently checking what can be triggering this issue.

2 Likes

2 posts were split to a new topic: Is it ok to use the Flasher 1.5.0 version

device manager screenshot attached. Thanks very much!

Thanks Guido - I tried version 1.5.0 but unfortunately it still doesn’t work, I now get the message ‘launch failed. Try reinstalling the app’ when I try to connect the reach. Tried both with and without the edison drivers installed.

Quite a mystery.

Especially trying to get a COM port created for USB-to-PC after finally getting it detected. Reach RS (non-plus Edison).

Hi Charlie,

Thanks for the screenshot! Just to be sure, have you checked all USB ports of your PC?

Sad to hear that!

Have you tried another USB port or USB cable? I was able to update both of my Reach Modules to firmware version 26 following the steps I detailed on the forum post I created here

1 Like

I have checked a few of the usb ports but not all, tried USB 2, usb 3/3.1 ports and a variety of cables. Can’t rule out usb port or cable issue I suppose, but nothing I have so far tried has worked. Thanks for the assistance!

Happy to report that uninstalling all the edison drivers, uninstalling the flash tool and rebooting then reinstalling worked! I’m not sure what exactly changed as I’m pretty sure that’s the process I followed on the first installation attempt, but all seems ok. Now to reflash my other modules :slight_smile: Cheers!

1 Like

Hi Charlie,

Thanks for sharing the update!

We’re now working on making the reflashing process easier and more straightforward!

1 Like

Hey everyone,

I just wanted to tell you that we have released the new version of Reach Flash Tool 1.7.0. Now there should be no issues with the reflashing process of Edison devices. You won’t need to reinstall the Edison drivers as the flasher will do it automatically.

You can download the new version of the Flash Tool in our Firmware Reflashing docs. We’ll be glad to hear your feedback!

3 Likes

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.