FATAL spi-dev and warning Kernel (this was not a problem then, RESOLVED)

I absolutely do not understand. Should we install the program into Raspi before mounting the Navio on Raspi.

When the RT program is started and the password registered, how to find the Raspbian office.

In what order do all that.

How to connect to MP.

I use 2 Raspberry Model B.

I tear my hair.

thank you

It is really hard to understand what you are asking for. The emlid docs give all the information to get you going.
The steps required are:

  1. Download the latest RT raspbian image from emlid
  2. Unpack the image
  3. Write the image to a micro SD card
  4. Insert the SD card into your Raspberry
  5. Connect a monitor and keyboard to your Raspberry, or…
  6. connect an ethernet cable to access yor Pi through an ssh connection
  7. type ‘sudo raspi-config’ and select ‘expand filesystem’
  8. download the apm.deb from emlid
  9. install the .deb
  10. run the Ardupilot variety of your choice.
  11. Connect with MP through an udp or telemetry radio connection.

I did not write how to do eacch step, because it is explained in detail in the emlid docs.
How to setup Ardupilot is explained in the ardupilot wiki:
copter.ardupilot.com
plane.ardupilot.com
rover.ardupilot.com

it is for this reason I ask

that’s 15 times that I redo all these steps and it does not work

I then paused the issue so that it does not work

Is it easier for you to understand now

I also have problem Kernel and SPi.

Module SPi-dev not found and WARN Kernel lacks cgroups or memory controller not available, not starting cgroups…warning, warning, warning…

I tried with 2 different RPi Model B and I have the same problems.

I have succeeded only in the beginning of the Raspberry interface. It’s not going away.

I can also write passwords. By cons I have to retype 5 or 6 times.

I know the APM 1.0 Pixhawk through the PX4 too. It’s been 6 years since I worked with it all.

I hope someone understands what I mean.

@JeanSeb

Could you please say what stage are you now at? Can you ssh into your raspberry? And what exactly are you trying to achieve?

Hello,

I format my 32GB SD card in FAT.

I write about my sd card 32GB emlid the RT program with Win32disckimager.

Then I have 2 partition. 1 and 1 Boot system.

I connect all devices.

I plug my SD card.

I start the Raspi. The boot is normally done.

I get 2 errors I mentioned. SPi and Kernel.

I write the login raspberry pi and password. It works.

I load the rapi-config. I extend the program.

I reboot.

I supported: wget http://emlid.com/files/APM/apm.deb

I charge: sudo dpkg -i apm.deb

So far everything is ok but there is nothing going on.

I tried sudo startx and also startx. It does not work.

I can go further than the login and password.

Thank you.

@JeanSeb

It’s actually not nothing! Everything seems to be right. Desktop environment is disabled on the image of Raspbian we provide, because we’re sure it’s not needed for the applications of Navio.

sudo dpkg -i apb.deb installs the APM software.

After it’s been installed, you can launch it, i.e. like this sudo ArduCopter-quad -A udp:<ip>:<port>.

Have you tried the last command?

Thank you for your reply,

So the error Kernel and SPI normal?

When I said that all devices were connected. I meant the keyboard, mouse, Ehternet, the HDMI display and SD card.

I have nothing plugged into Navio. I waited to see
if I prepared
Raspberry properly before.

this command line does not work: sudo ArduCopter-quad -A udp

I wonder if the program version
where you can modify the code,
if it is functional with APM directly as Emlid RT?

I would have opened the program with the Linux interface to change the codes that already exists.

Or if I have to build the complete code with this program?

Excuse my English. I have great difficulty expressing myself.

Thank you.

Could you please post the output of the command you’ve been issuing and the command itself? I don’t entirely understand what doesn’t work. Was there some kind of an error or the system complained about missing command. We need a little more details to help you out.

When I power on the Raspberry
lines scrolled where there raspberry drawings.

I see these lines appear in the error Fatal PCI and Warning Kernel.

I speak lines that happens when you turn the Raspberry.
Before writing the login and password.

thank you

These errors do not affect operation, spi-dev is simply not initialized at that moment, it will later during the load process. These indeed might be confusing, we will take appropriate steps so that these errors do not show up any more in the next release.

For now you can just ignore these errors.

Thank you to clear up this mystery.

I spent 2 weeks looking for errors.

I format my SD card often enough to destroy it.

It would be wise to give more details on the Raspi as start with Navio.

Mention that the Raspbian office is not on the RT version.

I do not understand how other users know.

Did I miss explanations?

What do you mean with Raspbian office? The actual office suite?

I speak the GUI Raspbian.
It is not with the image RT according to Staroselskiy

I wonder if the image to set the Raspi in developer mode
contains the same program as the RT.

I mean, if I take this picture
Is what I can operate the APM in the same way as with the RT?
and the opportunity to develop?

Or if I have to build code A-Z?

I would like to install the image to developer but,
I do not know if the code is the same as the image RT.

I do not know if I speak correctly.

I excsue, Jean-Sebas

Je me suis trompé