Failing Test 2 when upgrading from 2.23.2 > 2.23.3-dev

Reach RS2 Units:
I had updated to 2.23.2 and saw there were some issues with this release. After seeing today that there was an updated release, I updated my Rover just fine, but when I went to update my Base I ran into TEST 2 Failed. I have rebooted multiple times with no luck. It shows that the current version is now 2.23.3 but I can not click the “REBOOT AND GO TO APP” button because of the TEST 2 FAILED.

Any ideas what I need to do to get the update finalized and rebooted? The Reachview app will not see it. I have to go to it via Chrome browser at (hotspotted to my cell phone).

Thanks for any help

I re-flashed the unit using the Windows Reflashing tool (flashed ver reach-rs2-v2.22.3) and it still fails on Test #2.

Hi Tim,

It’s been a while since we’ve been in touch last time!

May I ask you to share a bit more detail on your hardware setup? Do you use a SIM card inside the Reach RS2 for connection to NTRIP?

I do not use a SIM card in the RS2. if I do RTK, it will be using a hotspot.

It is 9:15pm on Monday night here. I can do a remote session tomorrow morning. I have a iMac Pro running Mojave (hackintosh). I tried to SSH into the RS2 to reboot it but I found out the new RS2 units do not have root access. Please let me know what we need to do in order to setup a remote session. I can meet at 8am tomorrow morning (CST time zone). I do not know what time zone you guys are in. If we can meet sometime between 8am and 10am please send me an email link with details on how we will connect.


Tim Durham

I checked and it seems that you guys are 8 hours ahead of me (Moscow Standard Time) ?? I will check my email very early and see if you have provided a link to connect. I wake up at 5:30am (1:30pm your time). So maybe we can do remote session around 7am (my time) ??

Please let me know what is good for you.


yes, MSK

u: emlid
p: emlidreach

1 Like

Hi Tim,

Just answered your email with all the details.


The device behaves unexpectedly and it’s hard to figure out remotely what went wrong. That’s why we’re replacing it to continue the investigation and save time.