External Power Problem RS2

Connecting the external power to the RS2 with the violet cable to the positive and the black to the negative and a fuse in series to the positive cable burns the fuse when I turn on the RS2. I tried it on RS + and everything worked perfectly, what could be wrong? the red black and green wires should all go to the negative (-). If you can help me I will thank you. I’m afraid of burning the GPS


Red + black + Green to GND ?

Fuse 0.5 amper

1 Like


The charge consumption with cell phone charger fluctuates between 0.45 A and 0.55 A, when powered by a 12-volt battery, the load will be higher and the 0.5 A fuse will burn due to high consumption. I put the fuse to prevent short circuit and polarity reversal, the fuse must be tested with more than 1 A

1 Like

This may depend on the quick-charge potential of the external power circuitry.

The cell phone charger is providing 5V in your case and I have seen the RS2 take over 2A of charge current. The current should be lower with the higher 9V or 12V supply. If the wiring is correct then an undersized fuse may be the problem here.

Hi Luis,

I agree with @DetritalGeo.

Do I get it right that the fuse was burnt after you turn on the device, not after the power was supplied? In case it was burnt after turning on, it should be the issue described by Matt in the comment above.

1 Like