External GPS (Marvelmind)


We’re trying to get our indoor navigation system to work (Marvelmind) that uses an external GPS to spoof the signal and in the manual it says to use -B /dev/ttyAMA0 for UART or /dev/ttyUSB0 for virtual UART via USB. We’ve been trying to use these but I noticed that /dev folder does not even have these options.

We figured out that it works with -B /dev/ttyACM0 with the USB connection. Is our /dev folder missing something or is the manual outdated? We have Raspberry Pi 3 model B.

Could you please try our latest beta (it’ll be a release soon)?

I flashed it and now when I try to use “sudo apt-get install apm-navio2” it says:

Package apm-navio2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘apm-navio2’ has no installation candidate

I suggest reading the release notes! We deprecated this package in this release. Sorry for inconvenience.

Hello George: I have the same problem today while trying to install the apm-navio2. Hence checked the forum to find your response. The Docs page mentions doing this step. Hence tried it. Where do I find the Release Notes? Unless I have to build the binaries from the sources. Could you please let me know? Thanks in advance.

You don’t have to install anything: navio2-docs/installation-and-running.md at beta-docs · emlid/navio2-docs · GitHub

Also update to the opening post: Seems that the USB option is still ttyACM0 (not ttyUSB0) and the UART option ttyAMA0 is now visible. No problem with that but the old manual did not apply at least in our case.


I guess you ran into a problem described here.


@Vava shared a link you might be interested to look at. I suggest reading the docs and aforementioned posts. There’s a handful of useful information over there.

@george.staroselskiy @Vava

We are using the current Jesse Image from the NAVIO Website and were trying to use the Marvelmind indoor GPS.

We tried to use the indoor GPS both with the -E flag and the -B flag, we also tried both the USB and the UART connection. In each trial we also adjusted the Baudrate for the respective Serial port in QGC.

Everytime we plug in the indoor GPS the ardupilot crashes and cannot be restarted, however it appears as running. The LED on top of the navio blinks green. Both Mavros crashes, and QGC becomes unavailble.

Do you have any idea what we are doing wrong?

We set the configuration on the Beacon’s as instructed by Marvelmind (e.g. Baudrate 115200, and Protocol NME with all the messages enabled)

Please help us.