External GPS and compass not recognized on Navio2 UART

Hello Forumers,

I have plugged in an external GPS/compass combo into the UART port of Navio2. When I start arducopter, I get the following error:

pi@navio:~ $ sudo ./arducopter-quad 
Raspberry Pi 2/3 with BCM2709!

Init APM:Copter V3.4-dev (e391da7a)

Free RAM: 262144
FW Ver: 120

load_all took 469us
0 0 0 DataFlash_File: buffer size=16384
�	Q}�AK8963: Onboard compass detected
HMC5843: Could not detect version
HMC5843: External compass not detected
�	Q��Init Gyro*�	Q� **

I tried using the standard and latest build from github for arducopter-quad, same result.

The reason I upgraded to external compass is that the Navio2 compasses are not stable on my build.

Many thanks for your help!


All external GPS/Compass combos I know need an uart connection for GPS and an i2c connection for the compass. I use an original 3dr GPS/Compass on my Rover and it has two connectors. I also have a Holybro M8N GPS with compass and it has only one connector, but it is uart and i2c combined in a 6pin connector.

1 Like

Hi Sebastian,

Thanks for the reply. I realized it after posting this. I have now connected to I2C and UART and started arducopter with the proper options and it works. Kind of, still get bad AHRS error pos vert variance, but it is unrelated to my original question, I think.