Ethernet Over USB

Would it be possible to post directions for using the Ethernet over USB interface?

I see that this page is gone:

If I do screen /dev/ttyACM0 38400 I get a blank terminal with no errors. I suspect it connects but I have no indication of where to go from there.

My local wifi network (at work) is overly secure and not suited for this kind of thing. More importantly, this will be part of a beam-mapping system for a radio telescope and it would be good to be able to set this up in a radio-quiet mode.


Hi Justine,

Assuming that you are on Linux run ifconfig to check if you have a usb0 interface available. It will not appear until Reach has at least partly booted.

If you do, run sudo ifconfig usb0

Reach should now be available on

/dev/ttyACM0 that you see does not have console, it is used to send data. You can send NMEA position there by configuring position output to USB-to-PC option.

Radio telescope? Sounds awesome! Do you intend to use Reach to calibrate where the antenna is pointing at?

How can we make Reach access to the NTRIP caster through this usb/net portal on Navio2/raspberry pi3 board

Thank you Igor,

Yep, I can see usb0 once Reach is sufficiently booted. Debian deprecated ifconfig so I tried what I believe to be the equivalent ip command: sudo ip address add dev usb0

If I run the command again I get “RTNETLINK answers: File exists” the second time, so that seems good.

But if I try browsing to (in a browser, right?), I get the ole’ “Unable to connect” screen. The status LED is solid green by the way.

Thank you for clarifying the role of the non-console, I had the feeling it was taking input but not returning anything (cursor hesitates if I send any key strokes).

Radio telescope? Sounds awesome! Do you intend to use Reach to calibrate where the antenna is pointing at?

Pretty much. It’s a zenith-only dish and quite diffraction limited. We want a map of the sidelobes.


So now you have two networks and passing Internet connection should be a matter of setting up a bridge on your laptop. I do not have instructions on how to achieve that, but it should be a fairly standard procedure on Linux.

The interface will be available through the browser. What if you go to

Okay, sorry if I’m being dense, but on the PC that the REACH is connected to directly via USB, after doing sudo ip address add dev usb0 I should be able to browse directly to without any network bridge and see it, yes? doesn’t work either.

Hey, Justine

systemd-based(meaning most of the modern ones) distributions might give weird names to interfaces. For example, usb0 can become something like enp0s20f0u3c2. I would advice installing ifconfig(usually the package is called net-tools), finding the name of the interface Reach creates(dmesg will help), the running sudo ifconfig interface_name

Also, recent versions of Ubuntu have a tendency to lose this connection, so it might be useful to set this command for running every few seconds with watch sudo ifconfig interface_name

Thank you all for the help. As soon as I did it with ifconfig instead of ip it came right up on, and using usb0 as the interface.

Now I’m trying to understand how I might configure the Reach from the ReachView Updater screen to not connect to a wifi network and instead give me full access with Ethernet over USB. I believe I understand the point about having to setup a bridge to get the Reach on the Internet over my wired network, but is that necessary except to run updates? Even then, the options on the ReachView Updater screen don’t seem to acknowledge the possibility of not using wifi.

The whole idea of this first setup screen is to make you connect Reach to the Internet and to make you perform an update. This is done because we put out features and fixes very often and the software, that gets flashed at the factory, gets old pretty quickly. Once you go through it, you are free to always use USB.

This topic was automatically closed after 100 days. New replies are no longer allowed.