ESC's calibration

Hello , i have been trying to calibrate the esc’s using the all in once method which is as follows :
*turn on the transmitter ( i have a flysky i6) and put on full throttle
*connect power module to the lipo battery (this will turn on navio2 and the 4 esc’s )
*the navio2 now starts flashing blue and red and green color showing the esc’s are ready to be calibrated )
*now i disconnect the battery and reconnect it with the transmitter throttle still being at maximum , and now the esc’s are supposed to beep 3 times as i am using 3s lipo {that what the documentation says}

My problem is in last step , when i disconnect and reconnect the battery the esc’s keep giving the only one continuous beeping without being callibrated and the navio2 board repeats the stage before where it keeps flashing red , blue and green .
I tried to calibrate each esc alone without the navio2 board and it worked , but it seems that when i use ppm it has a different method that i can’t figure out . Can anyone help me ?

Have you tried doing the ESC calibration through Mission Planner as well? That might be a simpler method. Just connect to the Navio2 through UDP (the Raspberry Pi has to be connected to your computer network either wireless or via an ethernet cable). Just click on the green ESC calibration button, unplug the battery from the Navio2, then plug it back in. ESC calibration should start automatically after the Pi boots up and Arducopter runs again.
Once it’s done, unplug the battery one more time, and then plug it back in, reconnect with Mission Planner, and should be good to go.
Maybe see if that method works any easier.
Here’s the link to the ESC calibration page for Adrupilot / Mission Planner combo:
https://ardupilot.org/copter/docs/esc-calibration.html
EDIT: Not sure why that page doesn’t show it, but I’m referring to the screen in Mission Planner where you choose the ESC type, that shows the “Calibrate ESCs” green button at the top, just above the drop down menu where you choose ESC type.

Thank you for your reply , unfortunately i work on linux mint not windows so i am using apm planner 2 instead of mission planner which doesn’t have the option of callibrating through the software itself.

Hi @mohammadsaab,

I just want to clarify whether you go through this guide from the Ardupilot docs? If so, did you complete the radio calibration before start with ESCs?

Hi , yes i did the radio calibration first and it worked , but still the esc’s won’t calibrate . I also tried all the notes posted by ardupilot’s documentation in case of problems in calibration but non of them worked .