Error while building APM on Navio+ from sources

Hi everybody,

So, a few days ago, for no apparent reason, the sd where I had the raspbian image emlid-raspberrypi2-raspbian-rt-20150401.img, which also had Arducopter installed and working, had a malfunction, and I had to reflash it and install everything again. But when I was going to install the APM again via the sudo apt-get install apm-navio, it told me that the package could not be found, so I tried to do it via building it from sources. After a few tweaks, I could finally download the repository, but when i tried to run the make command, this pops up:
cc1plus: error: unrecognized command line option '-std=gnu++11’
compilation terminated due to -Wfatal-errors.
…/mk/ recipe for target ‘/tmp/’ failed
make: *** [/tmp/] Error 1
I double checked but my g++ is on its latest version, and it still pops the same error message, so my question is:
What am I doing wrong?

PS: My board is a Raspberry Pi B+, and when I try to download the other image on the docs, the green led tells me that the kernel can not be read

At the moment we only support Raspberry Pi 2 and Raspberry Pi 3.

This explains why your image doesn’t boot.

Have you tried sudo apt-get update before issuing the former command?

Okay, this is only explainable if you tried to use an ancient Raspbian we uploaded more than one and half years ago.

So basically I suggest trying the newest image on Raspbery Pi 2/3 with Navio+ and sudo apt-get update && sudo apt-get install apm-navio. This should get you back on track.

Yeah, I tried using sudo apt-get update and nothing changes, it still cannot find the apm-navio. The problem is that while I can without problem buy a Raspberry Pi 2 B and try the newest image, with the old image I was able to download the package not 3 months ago, and that is what I find wierd.

There is nothing weird about it! :slight_smile: We don’t support older images any longer. I think, I’m going to close this thread as the problem is kind of obvious and the solution is hopefully on its way. Feel free to open a new thread if a new issue comes up

This topic was automatically closed after 12 hours. New replies are no longer allowed.