Error : No pigpio interface for RCInput

Hi there,
I’m building a AuduCopter using Navio+ with RPI2. I made some test flights without problem last week, but it not work today suddenly.

  • The startup_log show “No pigpio interface for RCInput” after 2-3 minutes;
  • The Navio+ LED light keep on white, no flash;
  • No data from UDP in Mission Planner

I tried to reinstall the real-time Linux (emlid-raspberrypi2-raspbian-rt-20150401.img) and APM binaries (, but still don’t work.

Is it hardware problem? I don’t know how to trace the issue. Thanks for your advise.

@BellergyRC It is really weird that it happens on a fresh install. Do you have another RPI to test with?

Also, @george.staroselskiy might provide more insight on what sort of failures might cause described behaviour.

@igor.vereninov Thanks for your reply. I tried two RPI2, but both of them show same error.
I tried to start it manually:

sudo ArduCopter-quad -A udp:
Raspberry Pi 2 with BCM2709!
socket connect failed
socket connect failed
No pigpio interface for RCInput

I tried to get data from Navio+, the Navio board is working

sudo python
Temperature(C):  34.2283845425 Pressure(millibar):  1005.3713227
Temperature(C):  34.1802406073 Pressure(millibar):  1005.44058504

Is there any tool that I can check the pigpio interface directly?

One more thing, I removed a USB port and Ethernet port to save weight, would it be the problem caused?

I’m still tracing the issue. I found that the error message came from AP_HAL_Linux/RCInput_Navio.cpp (line 50)

pigpio = open("/dev/pigpio0", O_RDONLY);

if (pigpio == -1)
    hal.scheduler->panic("No pigpio interface for RCInput");

I found there is no pigpio0 in my /dev directory, but don’t know why.

/dev/pigpio0 will appear only after launching APM.

Could you please check the following:
After running APM with error about pigpio, run this in the terminal:

sudo pigpiod

Does it result in any error?

Theck run:


And check if there is pigpiod process running.

@mikhailavkhimenia Thanks for your help. It is the print screen below:

sudo ArduCopter-quad -A udp: &
[1] 2980
pi@navio-rpi ~ $ Raspberry Pi 2 with BCM2709!

After about one minute

socket connect failed
socket connect failed
No pigpio interface for RCInput

Then run pigpiod

sudo pigpiod
2015-06-03 23:10:44 initInitialise: Can't lock /var/run/
Can't initialise pigpio library

Then run top, there is pigpiod process running.

I tried to list /dev/ when ArduCopter running, there is no pigpio0.

Run the following:

sudo rm /var/run/

That should solve the issue.


sudo rm /var/run/

but issue not solved. :frowning:

When exit ArduCopter, there is no /var/run/, but pigpiod process still running.

Do you have GCS running on that machine (

No, I didn’t turn it on. I can turn it on and try again. Thanks.

Hi @mikhail.avkhimenia and @igor.vereninov, thanks for your support. The problem has been fixed when I reformat the SD card and reinstalled everything again. :smile:

Looks like I’m having the same issue… I will try and re-flash the SD card and see if that helps!

Also I’m very interested to see if you had issues after removing the Network and USB ports, as I would really like to shave some weight off this before I end up turning it into an octocopter!

Hi @Ben_Bissett My frame is 250 :grin:, weight is important…

I am also having the same issue. I have reloaded an SD card with the stock rt image and still get this error after building from source.

root@navio-rpi:~# ArduCopter -A tcp:
Raspberry Pi 2 with BCM2709!
2015-06-11 23:41:14 initMboxBlock: init mbox zaps failed
Can’t initialise pigpio library
socket connect failed
socket connect failed
No pigpio interface for RCInput

pigpiod runs just fine.

root@navio-rpi:~# pigpiod
root@navio-rpi:~# ps aux|grep pigpio
root 2207 12.0 0.1 8692 1544 ? SLsl 19:03 0:01 pigpiod

I did however change some settings in the /boot/config.txt file. I’m going to try again with a fresh SD card and load the apm package

I moved 9 posts to a new topic: PPM input not working