Error Injecting RTK

We are in the final stages of getting a quadplane up and running! Build is complete now just adding in the finishing touches, the main one being RTK GPS injection. We had this setup working on our firefly and were injecting the corrections into that but now we cannot get the same setup to work on the quadplane. I have attached a picture of the error message we keep getting.

Like I said before this exact setup was working on our firefly. rover is configured as follows:
The base is configured as follows:

When injecting through mission planner we are using TCP client with the IP address for our base and port 900.
I have been working on this for two days now and cannot figure out why it is not working, any help would be greatly appreciated. We are using a Pixhawk with arduplane 3.7.1 with quadplane support.

Is your base Reach connected via USB? If so, the IP address would be Can you ping it or ssh to it?

Also, have you updated your Reach’s to 2.2.5?

We are connected to are base via wifi we are able to get into the reach view app while being connected via its wifi. then using its ip we are running it as a tcp client. followed emlid reach ardupilot integration to a T. we have been able to send corrections on these using wifi and also via telemetry on another UAV with the exact same setup.

with the configuration of your base station you showed in the screenshot - reach sends corrections over uart;
you would actually need to set it up as tcp server on port 9000 with the way you described your injection through missionplanner;

1 Like

we have it setup that way and are able to inject corrections to the firefly but not to the quadranger, has anyone had any problems using rfd900x to send corrections. We have them setup to do rawdata like said but cannot get both bars to show up on our rover when we start the injection.

did you configure pixhawk’s serial connector to a 2nd gps with correct baudrate through missionplanner?

yes serial 4/5 has been configured to be a second gps with the correct baud rate of 38400 which is how we have them configured, I even switched out and put a new pixhawk in thinking it may have been the serial 4/5 connection. I went through the parameter list between our firefly6 and Quadranger and there were no differences other than the FF6 is running 3.8.0 and quadplane is running 3.7.1. I am now past my previous error we have gotten it to inject through mission planner just not getting both bars to show up on the rover in reachview?

is reach being initialized under mission planner’s status tab as 2nd GPS?

Issue solved maybe its coincidence but by upgrading our quadplane to 3.8.0 everything is working perfectly no issues. Has anyone had an issue using 3.7.1 arduplane with quadplane support turned on getting their reach to inject and show correctly in reach view? We are now able to get a fix in our office quite quickly using 3.7.1 we could never achieve a fix. Again this is with quadplane support turned on? To answer your question panky, yes it was in mission planner.