Error in starting arducopter process with the distributed Image

Hey, recently i’m trying to build new quadcopter on Raspberry Pi3 with Navio2.
And i have trouble with the distributed Navio2 Image.
I used Raspbian Jessie Image, which is “emlid-raspbian-20170323.img.xz”
After i set my arducopter configuration and start the arducopter process.
but then, after about 3 seconds later, arducopter process died.
I checked the configuration, but it did well.

I checked the journal log, and then it logs segmentation fault.

I’m not sure what i should do with this.
Is this problem related to some topics about spi and rcinput in the other writing?
Is it okay with upgrading my image?
I saw the some writings here, but i can’t figure out the reason.

This is the kernel version i’m using.


Thank you guys.

Could you please run sudo emlidtolland send us a screenshot? And also could you try the same with the latest image?

No INS available is a pretty serious error. Do you have anything connected to the Navio?

Yeah I connected the Receiver (D8R-XP) and ESCs to the navio shield.
But, i didn’t give power to the ESCs only to Raspberry Pi board.
Is that related to this?
I made several drones and it did well without power to the ESCs when calibrating.

Anyway, is there no problem with the image being distributed now?
I think it could be some hardware problem.

I don’t remember what INS is, but probably some sensors for the drone, right?
if the other guys have no problem in using the distributed images, i think it could be the hardware problem.

And i already upgrade my image with your advice on other article.
When i run sudo emlidtool , it just printed out the manual.
After i upgrade the board, i can’t access with ssh now.

Hello, Thank you very much, staroselskiy.
Due to your advice, i figure out the problem with our drone.
My colleague made new drone, and i check it out today.

As you said, No INS error message is critical.
So, i expect that there’s something wrong with the hardware part.
I checked the hardware my colleague made, and i found that the Navio2 shield was not locked hard.
After i made it correct, it works well now.



Thank you for your advice :slight_smile:
I think after Navio shield changed to Navio2,
there are many issues with the hardware (People do not assemble the shield tight).
I think someone who are under the trouble with Navio2, check the hardware first.

I’m glad you figured it out. But I couldn’t help myself but notice that your Navio is still not screwed down. It should be if you want to make it fly.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.