Error in APM Building from sources

Hi,
When I try to build APM from sources it gives following Error. (Attached a screen shot). Why this happen?? Thank you for your attention.

I use rpi2+navio2 with emlid-raspbian 20160718 OS.

Hello there!

sudo ln -s pkg-config /usr/bin/arm-linux-gnueabihf-pkg-config

Should do it.

@george.staroselskiy thanks for your quick reply. I tried above command. so previous error is gone. But now it gives following error.Thanks for your attention.

Sorry, I haven’t seen an error like this and I won’t be able to reproduce it on a Raspberry today.

I can suggest trying git submodule update --init

@george.staroselskiy I performed “git submodule update --init” again but it gives same error. so I format the SD card and install os again but it gives same error. “git submodule update --init” command performed with out any error. thanks for your attention.

There is a strange issue with future statements in mavgen.

For now, I was able to get around this problem by changing lines 12 and 13 to

from future.standard_library import install_aliases
install_aliases()

I’ll submit the bug to the issue tracker. Thanks.

Thank you very much.

I’m glad it helped.
This is a hack. though.

mavgen is requiring some new dependencies on master branch. This should fix it:

pip install lxml future

See: http://discuss.ardupilot.org/t/master-59366b0-fails-to-build/12132

2 Likes

I had the same issues. in /user/bin I found /usr/bin/arm-unknown-linux-gnueabihf-pkg-config, so I just renamed it. The I laso had to install future with pip.