Emlidtool tests failing


I have a Navio2 and RPi 3B+. I have assembled the pi and hat combination as per the documentation, and have proceeded with updating with sudo apt-get update && sudo apt-get dist-upgrade. This has all worked fine.

I have now proceeded to use emlidtool. The tests provided in this piece of software are failing, and I am not sure why (I’m new to RPi/Navio hardware/software). The attached images shows the test results and my hardware setup.

Lastly, my emlidtool version is 1.0.4.

Any help much appreciated.


Hi James,

Thanks for the detailed report. Could you please send us the output of these commands:

  1. lsmod
  2. dmesg | grep rcio
  3. sudo modprobe -r rcio_spi && sudo modprobe rcio_spi && dmesg | grep rcio

Hi George,

Thanks for getting back to me.

Please find attached the output of the commands that you requested.

Hi @george.staroselskiy - do you have any update on this please?

Hi @george.staroselskiy, I am also having the same issues as @James_Duffy, so I thought that I’d just make a reply to this already created conversation rather than making a new one. I have literally the exact same setup that James has shown in the images above. I’m also using a Raspberry Pi 3 Model B+. And I get the same results that James has shown in the last image above when I run those three commands that you told James to run.

One thing I noticed after trying some things is that emlidtool seems to be expecting a directory in /sys/kernel named rcio. However, I checked /sys/kernel and it seems that the rcio directory does not exist. Because of this, when I do sudo emlidtool rcio update or sudo emlidtool rcio restart, I get errors.

In addition, I notice that when I cd into /lib/modules, I see 3 different directories:

I’m assuming that 4.14.39-v7+ is the directory containing the modules that the system is actually using, since when I do uname -a I see Linux navio 4.14.39-v7+ #1112 SMP Sat May 5 12:01:33 BST 2018 armv71 GNU/Linux. Anyway, I notice that there do not seem to be any mention of rcio anything in the 4.14.39-v7+ directory. However, I notice that in the 4.9.45-94f47ec-emlid-v7+ directory there is a directory named updates, and in this updates directory are rcio_core.ko and rcio_spi.ko.

Furthermore, I notice that in /usr/share are directories named rcio-dkms and rcio-firmware. In rcio-dkms there is a file named postinst and in rcio-firmware there is a file named burn.gdb.

Does any of the above information give a hint about the problem, @george.staroselskiy?


Hey, I’m not sure if you’re still having problems with your emlidtool tests failing, but I think I figured out how to fix the issue.

So one thing I noticed was that the kernel seemed to be version 4.14.39-v7+, which appeared to have been released on May 5 of this year (as mentioned in my post above). Because of this, I guessed that the emlid guys must have accidentally updated the Raspbian image with half-finished work, so I looked for a way to “downgrade” the kernel to what seemed to be a working version.

So try this:

  1. Type in sudo apt-get install --reinstall linux-image-4.9.45-94f47ec-emlid-v7+
  2. Wait a bit… you’ll get a message asking if you want to stop the install. Select NO when you get this message.
  3. Do a sudo reboot
  4. When the system starts up again, run the emlid tests again. Hopefully, you should have all tests passing.
  5. By the way, do NOT update rcio because it seems that updating rcio makes the pwm test in emlidtool fail.

Edit: Oh wait, I just noticed that Internet no longer works after doing all the steps I mentioned above… I think I’m missing something, because I at one point got everything to work including Internet, but now that isn’t the case.

@kvnchowx - thanks for this. My tests are now passing!

But as you say, wifi does not work anymore… have you managed to solve this? I’ve tried various things (including the one shown here - simple hacks to make navio2 working with Pi3 · GitHub) and none have worked.

Guys, is there any chance you ran rpi-update?


I have run sudo apt-get update && sudo apt-get upgrade after Kevin’s reinstall suggestion.

Is that a bad idea? How do you suggest going forward?

Could you please post the uname -a here? No, generally, this is not discouraged.

Linux navio 4.9.45-94f47ec-emlid-v7+ #4 SMP PREEMPT Wed Aug 30 18:17:43 MSK 2017 armv71 GNU/Linux

That’s the right kernel. We’ll look into the issue why the mixup happened in the first place.

But either way we’re going to make a new release later this week. It’ll have a couple new features and a new kernel as well.

Is there anything I can try now to get the built in wifi on my Pi3 working?

Could you please type ifconfig -a and post the output here?

The easiest solution will be to reflash the image from scratch as I’m not entirely sure what could’ve caused the internal interface to disappear.


Well, here’s the thing… both James and I are working with the new Raspberry Pi 3 Model B+. The most recent flash of the Emlid Raspbian only seems to work for the regular Raspberry Pi 3. That is why we both had to do the upgrade to the most recent Raspbian through rpi-upgrade, which, as I mentioned in one of my previous posts above, put my Raspbian at Linux navio 4.14.39-v7+ #1112 SMP Sat May 5 12:01:33 BST 2018 armv71 GNU/Linux when I check uname -a. That is the reason why I did the reinstall of the kernel to the 4.9 emlid version that was available through apt-get.

However, as was mentioned above, this kills our Internet. And when I say Internet, I mean both wifi and ethernet.

And reflashing the image from scratch would just put us both back in the situation where we are unable to use it on the Raspberry Pi 3 Model B+.

Unfortunately, at this point, I have not yet fixed the lack of Internet issue.

I tried reverted back to before I did the reinstall downgrade to the 4.9 Emlid kernel, which was the point in which I had Internet. Then I tried to figure out an alternative to reinstalling the 4.9 kernel. I tried to find a way to compile the rcio-dkms stuff from Emlid GitHub repo at GitHub - emlid/rcio-dkms, but I could not find a way to compile the rcio-dkms stuff, as I kept getting errors about “No rule to make modules” or something like that.

Sorry for the delay, guys. We’re going to release the image with Model B+ support later this week. It’ll have ethernet support as well as internal Wi-Fi.

Great, thanks!

Thanks George. I look forward to the new image and will try that on it’s release.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.