Emlid Studio 1.1 won't update

Hi all,
I have Studio version 1.1 installed on my HP Laptop
The copies I have running on 2 other computers update without issue, however, this one seems stuck at Ver 1.1
I have tried to uninstall and that also will not work
My Computer specs are:

|Processor|Intel(R) Core™ i7-7500U CPU @ 2.70GHz 2.90 GHz|
|Installed RAM|6.00 GB|
|System type|64-bit operating system, x64-based processor|

OS info:
|Edition|Windows 10 Pro|
|Version|22H2|
|Installed on|‎1 ‎Oct ‎2020|
|OS build|19045.2364|
|Experience|Windows Feature Experience Pack 120.2212.4190.0|

Any suggestions?

Hi Adrian,

I’d suggest installing the new version from our docs manually, but it’s strange that you can’t uninstall the old one. What happens at this step? Do you see any errors?

1 Like

Hi kseniia
N\When I try to delete the app I receive no error messages.
Nothing happens
No response
Very strange indeed
It seems I may have to go to the root directory and manually delete the files.
However, I am hesitant to do this because I don’t know if any job files or settings might be located there
I have tried your suggestion previously and receive this message:
“The directory you selected already exists and contains an installation. Choose a different target for installation.”

So I simply renamed the folder to “Emlid Studio 2” and it accepted the updated app
However, that still leaves me with a duplicated program folder - no?

Adrian,

So, now you have a working Emlid Studio on the last version and the older Emlid Studio 1.1 installed in different folders, right? Does the Emlid Studio 1.1 work well, except for not suggesting an update and issues with uninstalling?

1 Like

Yes. Your conclusions are correct

Hi Adrian,

You can try to delete Emlid Studio 1.1 like this: go to the app root directory, open MaintenanceTool.exeRemove all components. Did you try that?

Also, may I ask you to send me your Emlid Studio logs to DM? I’d like to investigate possible reasons for the update failure. You may follow these steps to extract the logs:

  1. Press Windows + R to open the “Run” window.
  2. Paste %APPDATA%\..\Local\Emlid\Emlid Studio in and press Enter.
  3. An Explorer windows should pop up with Emlid Studio data folder. There should be the logs directory, which you should compress and send it to me.
    To compress it, you should right-clickSend toCompressed (zipped) folder.

Thanks!

1 Like

Hi Gleb
These look like great, comprehensive instructions.
I will try them over the weekend when i have access to the computer and send you the files.
Thank you

Hi Adrian,

How is it going? Did you have a chance to try Gleb’s suggestions?