Emlid RS2 PPK L1 only vs L1+L2+L5

Hi everybody,

I am a drone surveyer who bought an Emlid RS2 in order to plot GCPs to make accurate maps, and I have a question with regard to the PPK process and the benefit of multiband.

My workflow is straight forward :
I implant a local base by collecting data from a single point and post process it in RTKLib with a CORS Base Station RINEX.

Results are quite unexpected :
I get a Fixed Q1 solution when post processing with L1 only and only Float Q2 solution when post processing with L1+L2+L5 in RTKpost options.

Graphs are here under :

Considering these results, am I doing something wrong when trying to use multiband ?
What is the benefice of using multiband and RS2 vs RS+ in this case ?
Why do I get better results when post processing with single band ?

I thank you in advance for your time and answers.


If your GPS L2C number of sats are low or their SNR is bad, you are many time better off by processing L1 only, as the solution would use many more sats.

This is obviously only true if the baseline is relatively short.

@wizprod do you have any explaination about this ? Is it proper to RTKLib calculation method ? I was assuming that RTKLib would take the better of both worlds : L1 and L2C

Hi Luc,

It would be helpful if you shared your base and rover raw data logs so I can check why you get these results.

Logs.zip (4.4 MB)

Thanks. Sure here are the requested files.

In the ideal world, yes. In the ideal world you would have plenty L2C sats at well. However, due to the L2C signal still not being fully implemented in the GPS constellation, there may be instances where low observability and/or troubled SNR gives L1-only the edge. Obviously, then L1-limitations apply, in terms of baseline length, PPM and so on.


Thanks for sharing! I’ll look into the data.

Hi Luc,

I’ve post-processed your logs and was able to get ~100% Fix. The frequencies were set to L1 + L2. The filter type is Combined.

Reach RS2 can provide the following frequencies:

  • GPS/QZSS L1C/A and L2C
  • Galileo E1-B/C and E5b
  • BeiDou B1I and B2I

These frequencies included in the L1 + L2 notation in RTKPost. All the other parameters were set as we describe in our guide here.

Please make sure that you use the latest version of RTKLIB QT. You can download them from this docs section.

Let me know how it works for you.

1 Like


Thanks for having taken the time to process my data.

I must do something wrong because I cannot get these results. Still got full Q2 when combining L1+L2. Yet, I have followed your guide step by step and checked the RTKLIBpost version.

Could you provide me with screenshots from each “options” tab plz ?
Maybe the statistics one ?


Your parameters from the Options looks fine. Could you please reinstall the RTKLib QT on your PC and check if it helps?

Hi Ludmila,

Thanks again for your answer. Unfortunatly, I couldn’t get any different result even when trying with a new version of RTKLib QT. I also checked with another machine and I still get only Q2 in those conditions (L1+L2, combined)… which is strange since we processed exactly the same datas with identical parameters.

@wizprod I am confused about the role that L2C plays in this operation. Does it mean that the L2C with low SNR somehow takes the place of the good L1 signal in the case of post-processing with L1+L2 ? Resulting in Q2 solution. I thought L2 was used to “improve” L1 ?

What do you mean by “L1-only the edge” ?


Hi Luc,

Have you tried changing the nav file in RTKPost? If you have used the nav file from the rover, please choose the base file.

1 Like


Great ! I tried with the nav file of the base instead of the rover and it worked! Thanks a lot for your help and your patience.

So far I always put the nav file of the rover. Then, I searched a bit about putting the nav file of the base instead and found this on the forum :

So basically, we have better to put the nav file of the base most of the time ? Since it has more chance to have a clear sky view rather than the rover.

Thanks again you helped us a lot.


Hi Luc,

Sorry for the delayed reply.

It should work fine with the base and rover .nav files. Meanwhile, we’re looking into this. I’ll be in touch once there’s news about it.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.

Hey there,

We’ve thoroughly examined these logs. However, this is the single report on the issue that we have so far. That’s why this data wasn’t enough to define the possible causes of this issue. For now, we believe this issue won’t repeat. However, in case someone experiences the same issue, please let us know and create a new thread about that.