Emlid RS2 driving Raven Viper autosteer

Hello all, I have been experimenting with using an RS2 to output its location via serial (through the EXT port) into our Raven Viper pro in our Miller Nitro 4275 sprayer. The sprayer came with the Viper pro when we bought it used and it only has L1 Gps satellite capability with no RTK correction. We could add RTK to the machine for 15k but it would only have Gps satellites. I thought that before we spend money on a new guidance system (around 50k) I’d try to revive the old one with the RS2 as the receiver. I have successfully got the serial output of the RS2 to feed into the Raven system and the section control system as well but I am having a hard time getting the autosteer to work. The autosteer msg says No VTG. I have all of the messages that the machine wants turned on ( VTG, GGA, RMC, ZDA) at 10 hertz wich was specified by the documentation I found online. The only other thing I found was where the display displayed the differential age and differential ID was blank when connected to the emlid but when the old antenna was connected it displays normal age for the waas correction. Does anybody see any issues with my idea or is there a reason this will not work? Has anyone had experience with a Raven VIper pro? Is there a way to send my correction age to the other display? Thanks - Ian

I forgot to add that we are using NMEA protocall. So another question: is there a way to send the correction age in the nmea sentence?

Only a guess but your system is most likely looking for GPVTG, where the RD20 is sending GNVTG

1 Like

I am also in agreement with @jp-drain-sol , switch the talker code to “GP” with the new beta software.

Correction age and fix are included in GGA

Awesome this is the second Raven system reported that will steer off NMEA.

Hi Ian,

I agree with @jp-drain-sol and @PotatoFarmer. Old autosteers usually require a GP talker instead of GN. As far as I understand, you’re on Beta now, so this feature should be available. You can change the talker in the Position streaming settings:

I got back into the sprayer today and now I can see that the differential ID and the Differential Age is blank instead of dashed which indicated to me that I am receiving the correction information on the viper pro. I switched to GN from GP and no dice. The Raven displayed all of the same errors I get when there is no GPS input. Essentially it wanted nothing to do with the Emlid when I switched to GN. I’m not sure if the raven has some settings that need tweaking but I’ll read up on it and see what I can find. If anyone has a background knowledge on what GN versus GP is I’d like to get the “dumbed down” version just so I may understand it better. Thanks - Ian

P.S. I also switched the baud rates around on the Emlid and the raven to see if that had any affect but it seemed not.

Emlid is always 8, none parity, 1stop bit for serial comms, just check the raven has the same settings after the baud rate.

Have you tried swapping tx rx on one side or the other. Null Modem?

Both Baud rates have to match, try 115200.

Make sure on the rtk setting page refresh rate is set to 10hz.

The Talker Code “GP” is the original gps device NMEA standard talker ( talker being the name of the sender in a multi use communication buss ).

Is it possible for you to see gps data using a terminal program on a computer, to prove output from the RS2?

Commercial ag GPS still uses “GP” talker code for GPS/GNSS systems to date. So the gga sentence would output GPGGA.

New multi constellation GNSS, global navigation satellite system. Uses GPS, Glonass, Galileo, and Beidou Together. And would output GNGGA.

If the Raven accepts NMEA over RS232 this will work. Another guy made this work with a raven. I made this work with a trimble 150, with NMEA as well.

OK, Ill have to try out some of those today. I know that the settings in the raven do not match what you described. Ill change them then get back to you.

Raven autosteer with RS+

This was done before we were able to change talker codes or select sentences.

I can confirm that I have position data in the display, I can see my icon moving on the map as well as my boom shutoff controller is working. The only issue is that the smartrax (autosteer) is the only one that still displays the “no VTG” message

Could it be as simple as loose cabling to the auto steer module?

Can you actually see gpvtg coming out on a screen somewhere to verify its being sent?

You are so very close to making this happen.

How did the old gps connect wire wise?

Looks like there is a setting to check with different options for vtg, but the manual does not elaborate too much on the meanings.

Also try just GPGGA and GPVTG only at 10hz.
It looks like the smarttrax only needs these two. Its parser might not be able to handle the others.

1 Like

NOTE:The DGPS receiver must be powered up and connected to the ‘GPS Receiver/DGPS’ connector on the Viper Pro main interface or chassis interface cable. The receiver must also output the GGA, VTG, and either the RMC or ZDA NMEA messages to communicate properly with the Viper Pro.

I now think this is your error right here RMC or ZDA, not both

c. If an optional SmarTrax, automated steering system, will be used with the Viper Pro, for SmarTrax software versions:•3.2 and lower, set the baud rate to 38400.•higher than 3.2, set the baud rate to 115200.

Also this may be handy, Manuals are wonderful repositories of knowledge.

2 Likes

Hello

I had an simmilar issue with useing Emlid with AgLeader with Ontrac 3 autosteer. The problem was that the Emlid sends empty VTG-messages when rover is standing still or moveing slower than around 2km/h.

Try if it works while the rover is moveing faster than 2km/h.

I solved the problem by putting an arduino between AgLeader system and Emlid. I programmed the Arduino to modify the NMEA-messages when Emlid output not compatible VTG-messages.

It was a Reach Module that is single frequenzy. I decided to switch to a multifrequenzy system, so I bought a receiver from Ardusimple instead. It can be configured to send compatible VTG-messages even if the rover stands still, so I don’t use the Arduino any more.

2 Likes

Hi guys,

That’s indeed weird. I don’t think it should work that way. We’ll try to test it. However, is there any chance you have examples of such data from our devices?

Would it be possible to record some Position logs in NMEA format on your Reach? We’ll check what might be wrong with VTG messages.

Found my friends sprayer also runs the smarttraxx, the raven 300 GPS connects to the smart traxx first then then to the screen. I will have to switch to the beta, then I can give this a try as well. But the smart trax only calls for gpgga and gpvtg. Then sends the tilt compensated data to the screen.

A not working VTG-message when rover (emlidView 2.11.0) was standing still looked like this:

"$GNVTG,,T,,M,0.04,N,0.08,K,D*34"

I PM you (svetlana.nikolenko) a more complete example of data

I finally got time to sit down yesterday and try out the suggestion that the VTG error is linked to moving slower than 2 kilometres an hour. Lo and behold it worked!!! I was used to our John deere Autosteer that will engage when not moving but this raven only will work properly when moving more than 2 km/h so a very big THANKS to all of you who helped solve my issues and get our sprayer going just in time for 28 application season. Thanks again - Ian

3 Likes

Hi guys,

Just wanted to point out once again that we’ll check what’s wrong with VTG messages under speeds slower than 2 km/h.

1 Like

Thats also like Trimbles guidance too you have to be driving faster than a preset value to engage autosteer. But the no vtg message still seems strange.

I should try to read the raven 300 output to see what its vtg looks like.

Great to hear you are running!!! I think you will find the Emlid to meet or exceed the performance of the AG recievers. Especially with four constellation GNSS, and getting corrections right from your phone or lora.

1 Like