EMLID Reach RTK not working and GPS data cuts out for 40 seconds

I’m trying to configure EMLID Reach RTK GPS Module. When we collect data, it looks like the data collection cuts out every 100 seconds for 40 seconds. Also, when kept in one spot, the GPS location fluctuates in a range of 10 meters.

Corrections are inputted through TCP and position is outputted using UART to an Arduino. In post processing, we are collecting only the $GPRMC stream from the NMEA data.

I assume that the 10 meter fluctuations means that RTK is not enabled properly, but to my understanding I set everything up properly.

Also, I have no idea why the GPS cuts out for 40 seconds at a time. It’s like clockwork, every 100 seconds almost exactly. We’re using the GPS outside in an area without too many trees or buildings.

Which Reach FW version ? Try 2.6.0.

that’s the version we’re using.

I would 1st login into the Status page of the ReachView to verify if you are getting corrections, Float, or Fix


While collecting data, it constantly goes back and forth between single, float, fix, and cutting out altogether.

Also: our uncertainty sometimes goes up to 30 meters.

additionally: Looking at your screenshot, I noticed you had a baseline of 1000 kilometers. How is that possible?

This looks like a buffer overflow in your Arduino. Which status do you see in ReachView during experiment?

Okay, I fixed the Arduino buffer and it’s no longer cutting out for 40 seconds. Also, I went to a more secluded area and that fixed the results a little bit.
However, we still have a range of 2 meters. The solution status almost always says “float”. We really need it to get fix, but that never happens.
In the “base mode” tab, the “base coordinates” option won’t let us choose average fix or average float. If we do this, it just says “waiting for fix/float status” indefinitely. In order to get RTK to work, we had to input the coordinates manually (which we did by copying and pasting the obtained Reach coordinates and height). After doing this, RTK works, but it still says “float” and never “fix”.
So basically, our coordinates are still up to 2 meters off and the solution status is always float and never fix. Also, the baseline seems to fluctuate a lot.

We would be very grateful for your help.

I’m working on the same project as Allison. We just ran another test using a ground plane and expected to have better results, but after leaving the GPS in one place for several minutes, our data was off by 16 meters in each direction, and that’s after taking out the outliers. If you include outliers, the data varied by about 50 meters. Do you have any idea as to why this would happen? We even moved to a more open field.

We were also able to get average single to work, but can’t make average float or average fix work. Our solution status made it to fix a few (brief) times during the testing, but the baseline still showed numbers such as 50 or 80 meters when the base and rover were only 3 meters apart. Is it possible that the base and rover are too close together? We are looking for any suggestions at this point.

You may get better response by uploading a picture of your setup, if possible, and your configurations and raw data files so bide and TB_RTK can give you some help.

I,m getting less than 1 mm resolution ENU under poor skyview on both Rover and Base for minimal baseline. Not saying you should expect this, but must be something in your setup. Without knowing your setup, it’s difficult to respond. Good luck.

These are some screenshots of our settings and data collection. The data was collected in a large open parking lot, so I don’t think the surroundings were the issue. The baseline of about 3 meters seemed reasonable, but then without moving either antenna, the software thought the baseline became 20 m and then 50 m.

Here’s some pictures of our physical set up. We just tested it on a car this time since we were in a parking lot.

Thanks for the help

Ist a bit hard to read from the images, but low SNR level and pictures posted, tells me that you may have a bad setup for the antenna. You need better antenna conditions.
Propper groundplate is crucial, AND having no interfering object above the grounplate in a nearby area.
Also keep the antenna as close to a leveled state as you can.

I agree with TB_RTK. The SNR levels seem low. Doesn’t necessarily mean low signal levels, but can be high interference from somewhere. Computer? CellPhone Towers?, auto receiver, auto computer, etc. I would first try lowering your SNR Mask to 25DB to see if that helps. If you have saved logs and done post processing, you can see if there are not enough valid satellites using RTKPLOT. Also, USB cables vary in quality. You may want to try a different cable.

We tested it again, and made sure that the antenna setup was correct and that all devices were below the groundplane.
When we began our setup, a float status was immediately obtained; but our rover GPS took about 5 minutes to get in the correct position. After this, we had pretty good centimeter accuracy for about 3 minutes (although fix was never obtained). After 3 minutes, the position started wondering a couple meters again. We also tried lowering the SNR mask to 25 and it didn’t seem to make a difference.
I got some responses about making sure we input the correct latitude and longitude coordinates. However, I just use “average single” to determine the base coordinates, so that should be correct.
Is this still an issue of not having a good setup? Our SNR remained just as bad as it was before, even though the accuracy was better than last time. If it IS a problem with the setup, I have no idea how I can make it better. Raise the antennas up even higher?

So, no better SNR level then before?
Do you have a picture of location with setup to share? You could send as IM

The groundplane needs to be symmetric. It should be square or round.

What is the best size for the groundplane to be? Is bigger better?

Make it 100x100mm and that will be good.

Alright! Now that we have symmetric groundplanes, we are able to get “fix” status almost all the time. The accuracy is way better now. When we kept the rover in one place, the range was mostly accurate to about 5 centimeters after removing outliers from the data. However, the signal to noise ratio is still really low (around 17-20). Is there anything else we can do to improve this data? (we are using a 10x10cm aluminum foil square groundplane now).

Could you help me I have good snr signal but i can’t start with single solution