Emlid Reach Module Communicate with Matlab

When i try to communicate Emlid reach Module with Matlab simulink using RS232, I could not find the header as shown in the Emlid ERB Protocol. So i could not parse the data properly. I have spend much time in parsing the Uart data, but did not get any results.

The connection is shown as the following picture. I have already connect with the ground and RX,Tx cable and then convert into USB, then the simulink i get the signal, but the header always couldn’t match the protocal provided. Has anyone meet the similar problem? Hope can get answer at here.

Hi Lin,

Welcome to the community forum!

We haven’t tested the Reach output with Simulink, so I can hardly tell whether some settings in the application are causing improper data parsing. Have you tried testing other formats? You can check the industry-standard NMEA format, for example.

Hi

I have ever tried the NMEA format, but meet the similar problem. I do not know where is the problem come from. Is there are some specific setting in the RTK? I think it should be the same thinks with other platform. How do you usually parse the data? could you provide some other method?

Best Regards

Hi Lin,

RTK settings shouldn’t affect this behavior. Did you try to check whether the position stream is accepted by your PC? You can access the Serial input ports of your PC to check if the data is generally accepted.

I can barely provide you with such details as I haven’t tested particular methods of parsing the data. However, I believe you can check how to parse the data coming from the serial ports using the Python scripts, for example.