Emlid Reach M2 discrepancy logging

Hi Good Day, I am a newbie member of this group and hope to find answers to our problem,
So we have a new Multirotor with Reach M2 as Rover and Reach Rs2+ as the base.
We have tested the unit last 2 weeks without having a file discrepancy with the following flight details with Mission Planner:
Flight AGL: 60mtrs
Speed: 16kkph
Trigger Interval: 2.53secs

Yesterday, we conducted another test flight with different areas and these are the flight details:
FLight AGL: 120mtrs
Speed: 30kph
Trigger Interval: 2.70secs
Weather: Cloudy
Does the weather also affect its logging?
Here is the event log of the rover from our latest flight and clearly shows the missing log:

Looking forward to any help thanks.

As I see from the drone logs, the signal-to-noise ratio (SNR) is fluctuating and it has lots of cycle slips. SNR indicates how good the reception is while cycle slips appear in the log when a satellite signal is interrupted or there’s electromagnetic interference. This could be the reason for the missing time marks.

I recommend isolating the receiver itself and the cables that lead to the GNSS antenna and the camera.

Also, please update your devices to the latest firmware. The latest stable firmware is 31.6.

1 Like

Do you have samples of the cable isolation from the Rover Side?

For the update we will do the firmware update and do another test to check the issue.

Hi ruth,

I have tried to update the firmware now for the Reach M2 but could not get the latest version of 31.6 but only 31.3

Their Cloud Services may be down again? Try again in the morning when they get in?

Hi Ruth,
I have tried to update the firmware as you have advised but it could not find the 31.6 version and just stayed to 31.3

Hi Jason,

Let me answer for Ruth.

Usually, when Reach can’t find an update, it’s not connected to the internet to update to the latest firmware. Could you please try connecting your device to a Wi-Fi network or your phone’s hotspot (with an internet connection) and try again?

If your Reach is connected to the internet, please check if you can see an update in the Emlid Flow application.


I just finished the firmware update, yes your correct my internet last time were not good and that caused the update failure.
We scheduled to do the test flight next day and will give you updates after it.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.