Emlid Raspbian Image 20160718 not working on Pi Zero v1.3

Has anyone gotten emlid-raspbian-20160718.img to work on Pi Zero v1.3? I just tried today and am getting the Rainbow Screen of Death (see http://suniljohn.com/wp-content/uploads/2013/11/rainbow_screen_of_death.png). My activity light blinds 7 times which seems to indicate “kernel.img not found” (according to http://elinux.org/R-Pi_Troubleshooting). The same SD Card works on my RPi3. I’ve also tried regular raspian image on this PiZero which works fine.

On the card, in boot, I am seeing “kernel7.img”. So perhaps something is expecting “kernel.img”? (Shot in the dark?)

Update: Tried setting “kernel=kernel7.img” in config.txt (https://www.raspberrypi.org/documentation/configuration/config-txt.md) but doesn’t seem to do anything aside from preventing the activity led from flashing at all. =/

Hello there! As of today, we have stopped supporting BCM2835 based boards (RPi Zero being one of them). This is certainly possible, but that’s time consuming and we I cannot accurately get an ETA on this one. Raspberry Pi 3 is not an option?

Thank you for your response, George. Also… eeeeap! :stuck_out_tongue:

It’s too bad; I purchased the Navio2 with the intentions of using it for my Lumenier QAV250 build (where weight is a big issue). I noticed that the emlid docs suggested that the Pi Zero didn’t have the specs for ArduQuad but I had planned to write my own software to get around any issues on that front. I would love to use the RPi3 but just can’t get it to lift off the ground even at max throttle due to the weight.

I’m a software engineer and would love to donate some of my free cycles to try and help implement support for BCM2835 based boards like the Zero. Perhaps you (or others) might be able to point me in the right direction so I can be of some assistance?

All the best,

Bryan

I think https://github.com/emlid/linux-rt-rpi seems like a good place to start. :blush:

The difference between Zero and RPi3 is just 31g. If your Copter does not lift off with the RPi3 it will not lift off or be flyable with the Zero.
You should have a look at your setup. Did the copter fly before with another Flightcontroller?
My racecopter hovers at 30% throttle and has so much power, I could fly it with a 4s 4000mAh 400g lipo.

Thanks for the specs comparison. In a week or two I’ll review individual weight contributions of each component and see where I land. Might be better if I go with the Naze32 as proof of concept and then hop over to the Navio2. ¯\_(ツ)_/¯

Still would like to roll with the PiZero for better performance at some point anyways.

Take care,

Bryan

to get your copter in the air you might want to have a look at your motor/prop/lipo combination first;

RPi3 has drastically better performance.

I think @duskstriker meant better flightperformance through lower weight. But I still doubt 31g make such a huge difference.

That’s correct @schuermannsebastian. By “performance” I was thinking “agility” (opposed to “processing power”). Anyways, I did figure out my main issue.

After reviewing my set up again, I found that I had the props on the wrong motors. Whoooops. :stuck_out_tongue: Now things are working perfectly with the RPi3. I’d still like to roll with the PiZero but I’ll reprioritize that later on after I get the rest of my systems online.

Thanks again for all the help and feedback everyone! I really appreciate the patience as this is my first build.

@duskstriker

Sure! Feel free to ask whatever you want!