Emlid / Pix4D

I completed a test using a RS+ base and rover to mark GCP. I then flew it with the Pix4D/Drone Deploy application. when I input the GCP file it says that my coordinates do not match. Plugging them into google earth brings up the right location.

I have been using Pix4D/Drone Deploy for a while and am experimenting with RS+

I do not have NTrip

Is this when you are importing the CSV coords file?

yes

Are you importing Lat/Lon or YXZ?

1 Like

It was YXZ

When this happens to me the yxz coordinates that I have are not globally relevant. As in they are not true coordinates transformed from wgs84 where they are located in a CAD file. This is one of the reasons I cannot stress enough how important localization is because with a localization the coordinates do not matter. You could set up on an arbitrary coordinate system (5000,5000) derived from a CAD file just fine.

Ok. So what do I need to do in the future? Or to fix this test?

Try the same project uploading WGS84 coordinates. That will match the drone regardless of what the CRS says. Problem then is that if you try to match it to a design/CAD file you will have to shift it.

Ok, Ill try that. Should I do anything different in the field obtaining the GCPs

Well, with the Emlid you would have to be surveying with WGS84 coordinates unless there is some other way to use a local CRS and still get the WGS84. Honestly I don’t recall what the current stock Reachview has. You are using Reachview right?

Yup. We dont have a free ntrip here

Hi @lantz65,

Have you had a chance to try uploading the GCPs in WGS84?

XYZ coordinates from the Reach is the ECEF coordinate system. It doesn’t seem to be supported by Pix4D.

YXZ is definitely supported in Pix4D, but the input file and mapping has to be done correctly.

When you post processed your GCP data from the Reach RS, you had to have selected the format of the export. In Pix4D you have to specify the CRS that your GCP data is in. It is very easy to get it wrong in the Pix4D settings. The GCP’s do not have to be in WGS84 (which is what your image data is in). So just make sure you have the correct GCP format setting in Pix4D. Otherwise you will get an error.

1 Like

So what format does reach use?

Reach always uses Lat/Lon/HaE. Height above Ellipsoid. GCP’s can be converted and are subject to the need of the project so sometimes they can be YXZ (northing, easting, elevation (ft)) in our area. Pix4D shoudl be able to accept both, but you have to make sure your output format matches.

1 Like

Hi James,

How is it going? Have you managed to upload CSV from Reach to Pix4D?

Not yet. Im still trying to figure out which setting it is in pix4d

James,

Could you please share the CSV with me?

You can send it in PM if it contains some sensitive information.

Hi James,

I’ve managed to open your CSV file in Pix4DMapper. Please let’s cross-check the settings:

  1. The coordinate order is longitude, latitude, altitude

  2. The coordinate system is WGS 84. You wrote that there are a few options for WGS, but you need just WGS 84

  3. In the Coordinate system menu, tick the Advanced Coordinate Options and set Geoid Height Above WGS 84 Ellipsoid [m] = 0

Please let me know about the results.

You also said that there is some tree cover on your site, and you had Float solutions only. Could you clarify how dense this cover is? Any chance you can share some photos?