Emlid NTRIP Caster

Having some issues connecting to the Emlid NTRIP Caster on our RS2 base. The directions on the webpage don’t have a username for the base credentials. The directions for the rover, however, has a username. If I leave the username blank when connecting it fails. If I use the rover username it connects but I get a message stating “connected to HTTP/1.0 401 Unauthorized.” Any suggestions on how I might correct this issue?

I guess Emlid is all over this when they get a chance.
Just to rule out few thing.

  • Is you user name made up of credentials valid to the system? e.g try to simplify it and check for typing error.
  • you are using the user name from your account here https://caster.emlid.com/
  • have you tried changing user and or password in your account https://caster.emlid.com/
  • do you have other rovers connected?
1 Like

The Base does not require a user name .

I had that appear when I had changed the password In the caster page but still had the old password on the unit

Thanks for the prompt reply! I updated the password and removed the username info. It won’t accept the changes, however, without username in the input.

Thanks for replying so quickly! I tried all of your recommendations but unfortunately none resolved the connection issue :frowning:

Are you connected Via a sim card on rover or hotspot?

1 Like

As far as I understand it, Emlid needs to connect to wifi since I don’t have it sim card enabled. The app and base our on the same wifi. It seems to be connecting but not giving me authorization.

In base mode tab on your Base there is no input for a username only on correction input on your rover

What Reachview version do you have?
Could you post a screenshot of the error?

That is correct. The in Base Mode you would be correcting the output with NTRIP not the input. Per the Emlid guide to receive NTRIP corrections to the base it should be enabled as Base Correction so that it’s a correction input: https://docs.emlid.com/reachrs/common/quickstart/ntrip-workflow/. Maybe I’m overlooking something.

Wer’e using the RS2 with Emlid v2.22.7.

.

The first screenshot is without the username. Hence, it won’t accept the update. If I use the rover username from the caster website it will accept the changes but it won’t authorize–see second screenshot.

Many thanks for all the help and recommendations.

You are in the wrong menu for base configuration.
Use this one for the base
https://docs.emlid.com/reachrs2/reachview/base-mode/#correction-output

And this one on the rover
https://docs.emlid.com/reachrs2/common/reachview/correction-input/#ntrip

3 Likes

I’ll give it a try. Thanks TB/ Dave for your patience & advice.
k.

1 Like

Hi @kvand,

Let me sum up the info in this thread.

To configure the connection with Emlid NTRIP Caster, you need to do the following:

  • go to the Base mode tab on the base’s ReachView
  • choose NTRIP as Corrections output
  • enter all the necessary credentials: IP address, password, port, and mount point for the base
  • go to the Corrections Input tab on the rover’s ReachView
  • choose NTRIP as Base correction
  • enter all the necessary credentials: IP address, username, password, port, and mount point for the base

After this, your base and rover should be able to transmit/receive the corrections via the allocated mount point.

Please, keep me updated on whether it works for you.

I’d also like to thank @TB_RTK and David for the input.

2 Likes

Sorry for the delay on the follow-up questions.

I’ve got the both the Base and Rover connected to the Emlid NTRIP service. Since I’m new to NTRIP I’ve got a couple of questions:

  1. How do I know the distance between the RS and the NTRIP tower? Shouldn’t the Rover “baseline” display the distance? Mine lists it as 4.40m which seems to be the distance to the Base and not the closest NTRIP caster. The Rover “base position” coordinates are not moving so I assume that’s because the Base “position outputs” are being corrected. Yes?

  2. Both the Base and Rover are connected to Mount Points: MP644. Is that correct? Or should I be choosing different MP? My closest CORS station is only 7km away.

I’m testing this inside so forgive the poor satellite coverage. Any help would be greatly appreciated!


I just realized that NTRIP is just a means to broadcast corrections from my Base. It’s not RTK corrections from other casters. Correct?

Might someone know how I get corrections from CORS?

That is correct

That completely depends on your needs and your location in the world. Lots of paid and free solutions.

1 Like

I’m in Philadelphia, PA. The nearest CORS station is only 7km.

This thread might help: NTRIP RTK Cost

Google is your friend. Do a search for PA CORS.

Here is a good link but not sure how up to date: