Emlid Flow crash

Hi, I have an issue with the Emlid Flow app, the software crash with the latest update when I try to open a job, iPhone 12 pro iOS 17.3, V 9.11.1

Same here. The app crashes the moment you try to open a project. iOS app version 9.11.

Danilo and Ben,

Is there a chance you have WMTS layers added to your Emlid account? If yes, let’s try removing them from the account in Emlid Flow 360 and accessing projects in Emlid Flow after this. Please ensure you also have internet access on your phone for the account sync.

1 Like

@kornel.nemeti While I do have WMTS layers on some of my projects, I’m not able to open any project in the app. Even the “Demo Project” makes the app crash instantly.

I have one project with it, I erased from the project, and still have the issue, I don’t know how to erase it from the account.

Done, I erased it and it’s worked.

Thanks

@kornel.nemeti Deleting all WMTS layers from flow 360 made the app work again. So it looks like that’s causing the issue. I tried to add a WMTS layer back again, and then it stopped working.

This functionality needs to be fixed though because we rely on using WMTS for bringing in current drone ortho maps.

3 Likes

Hi Ben and Danilo,

Thank you for the update. Yes, we caught a bug on iOS that causes crashes if you have WMTS layers in the account. Our devs are already working on a fix for it. Once it’s out, I’ll let you know.

I also wanted to note that WMS layers should work fine. It may be an option to use them as an alternative for now.

2 Likes

@danilostgo @kornel.nemeti It looks like the update is out on the App Store now, and the problem is fixed.

2 Likes

Hi guys,

Yes, we released a fix in the 9.12 version of the app. Ben, thank you for testing it! Glad to hear that everything works fine.

1 Like