Emlid

Emlid Edge Motor Stopping During flight


(Antonios Antzoulatos) #1

2018-11-23 07-38-12.bin (1.6 MB)
I did a test flight today in order to start autotune, but noticed during flight that occasionally 1 or 2 motors would stop spinning. i tested multiple times after that ESC and motors without a problem, but with this issue, i did not trust to start autotune (even though PID were way off)
Before this flight ESC were calibrated as asked by the wiki and after the flight i calibrate once more direct from receiver THout to make sure is correct. Also noticed on RC3 that min/trim value for some reasson is the same
May i have some help with this? i have attached a log


(Marc Lebret) #2

Hello,

Quite large bird?

Rc3Min and Rc3Trim are the same value.

You could tune your transmitter (RC3 end points) in order to have endpoints around 1050-1950

You have:

RC3_MIN| 1182
RC3_TRIM 1182
RC3_MAX 1855

I do not think it is related to your motors problems. For that you have to check plugs and solders between ESC and Motors. If you have low KV and large propellers, you may experience desynchronising. It depends of the motor and the esc settings.

Do not try Autotune before sorting motors problems. If it a synch problem, you will crash during autotune as it is quite aggressive.

RATE_ROLL and PIT_D are too large. You can lower it to 0.01

If you have Emlid Edge power unit, your Amp multiplier seems quite large (I have 63).

I had some refuelling landing at your airfield when commuting from France to Middle East (Nord 262 Fregate and DHC-6 Twin Otter).

Marc


(Antonios Antzoulatos) #3

Hello @mlebret,
Apologies for late reply but all day yesterday i was in bed with some fever and today i have come to do testing at the field and hopefully tune the whole rig.

Yes this is a large bird and has done a few tests. Radio has been calibrated many times but for THR i have found that no matter if i calibrate with MP or QGCemlid2.4 that it always calibrate throttle as such, with min and trim the same. I checked also servo1-8 and all values are 1100-1900 with middle 1500, even though i tried to calibrate with the instructions and eventually calibrated through and 8-1 cable direct from THR channel on the receiver. I must say that ESC’s here are DYS 50amp SimonK and XM5015TE-6 motors. I also tested on a Pixhawk and a pixracer and the RC3 was the same as also the same on a number of logs from previous builds (This is not a complete build, but an FC change from broken wookong to the emlid edge). This specific controller i am using for the first time and i must agree that i did a couple of setting mistakes, with the biggest being that when i did autotune on roll the first time i forgot to lower FILT to 10 from 20, as also fixed the FC on very soft dampening balls, thus causing the complete tune to be WAY off, thus the wrong D value. For now i tested zeroing P and I and tuned D to the point that it would not oscillate and added P&I eyeballing it so that it will be flyable. Checking the logs i did find that on the moment i saw the propeller being completely halted in the air i was able to see on the log that the RCout was as low as 1160? (if i recall) this is what i am trying to find out, why is this happening. I know that on that test D was high as also P and I and it might be related to that, but i dont want to take it in the air only to find that it happens again during Autotune, thus end up flipping while flying. luckily when poropeller did stop in the air i was able to land safely. Looking for ideas and suggestions and i thank you for yours.


(Antonios Antzoulatos) #4

I have just noticed, while trying to calibrate radio and ESc once more that if i make the radio have values lower from 1180, even though i calibrate ESC again (and again) that i have huge deadband for the ESC to start. When i take deadband to 1200, then all ESC start together and almost instatly as soon as i move my stick. I have a feeling these ESC need PWM 1200-2000 and this has me concerned now.


(Marc Lebret) #5

Hello,

Some work to do but not impossible to solve this part:

With Edge connected to PC (QGC), you will setup your Throttle channel (transmitter).

Adjust your TX endpoints in order to have around 1050–1950 play.

Here are the copies of my settings in the Radio Calibration page:

LowThrottle
My low setting is at 1064,
EdgeHighThrottle

High is at 1976.

When done, save the calibration or change the settings in the RC3 part:

RC3

RC3_MAX, RC3_MIN, RC3_TRIM…

To be sure to have the good ESC calibration, do it with a receiver and the 8 in 1 plug. Remove the propellers before…

When done, go back on the Edge settings, Motor side.

You will adjust MOT_SPIN_ARM to have all motors rotating when you arm. I have 0.10

And MOT_SPIN_MIN (minimum setting when flying) at around 5 to 10% more. I have 0.15

My MOT_THST_HOVER is at 0.290

You do not want to see motor stopping in flight but you also want to be able to descent.

When done, go back to fly and report feedback.

Marc


(Antonios Antzoulatos) #6

Hello again and thank you.
All day i am at the field because i decided i must solve. As i see your trim is also same as minimum, but having take what you said about PWM min and max i had desiced to make radio transmit 1050-1950. After i did that and calibrate radio again with QGC instead of taking my 8-1 ESC calibration wire i did as you also suggest here, one by one. after that i installed on FC and decided to test. As i told you i did also pid estimation by zeroing P&I and taking D to the point of Oscillation and then backing it off. after that i eyeball the PID and so far they dont look bad (atleast to take it off the ground when i feel safe with ESC) on the first 3 test all seemed fine but on my 4th, one motor again seemed to stop. I will test once more but i think you are right when you say Mot_Spin_Arm to be 5-10% more, since i set mine only 0.02 more from where i found that all motors work. still it seems to me wierd that one motor or two (in my previous tests) seems to “reboot” and from first test this was caused it was not always the same, so this is why i am sure now that its either FC/settings related or simply the OLD SimonK issue on large rigs. What type of ESC are you using? SimonK or BLheli?
2018-11-25 14-03-08.bin (2.4 MB)


(Antonios Antzoulatos) #7

Also what RC_speed are you using?


(Antonios Antzoulatos) #8

After More investigation (since this was not a complete build from me) i was able to narrow down the speedos, only to find that manufacturer states as BEC:Opto! This means i need to make a common ground and need to power the ESC’s from a BEC. (atleast this is ,how it was in the past on ardupilot and i think it still is) I need to open them up one by one replace all BEC cables to include also the red wire. Does anyone know atleast if i can properly power the rail of the Edge so i can power up properly the OPTO ESC and finally solve all issues? @tatiana.andreeva can anyone from Emlid Help out with this?


(Marc Lebret) #9

How I do it (I have also Opto ESC).

Without propellers:

1: I unconnect esc plugs 1 to 8 from Edge.

2: I connect all esc to the 8 in 1 plug to the Rc3 out of a receiver.

3: RC Transmitter ON, Throttle at Max

4: I power the receiver with a Bec

5: I power the main power plug of the copter (in order to have power to the esc/motors) with a 3 or 4S battery.

6: When ESC calibrating tone is OK, I reduce Throttle to min, All esc are calibrated, I test all motors are running (low throttle).

7: Unplug main battery, receiver battery then redo the wiring to the Edge.

Marc


(Marc Lebret) #10

You can really improve these settings:

Here is a copy of your params (left side) and mine (right).

I have MOT_SPIN_ARM at 0.15 and MOT_SPIN_MIN at 0.18

I have BLHeli ESCs (DYS) but they are no more in production. Speed is set at 490 (default).


(Antonios Antzoulatos) #11

I think I found the issue.
The person that did original build used DYS 50amp SimonK but OPTO esc and he had connected only ground and signal. This means esc does not have OR take 5v from any place and if I recall correctly from arducopter wiki, I must power these via a separate BEC. The mot_spin_arm/min is not wrong. Simply the esc reboot when under lots of power due to lack of Bec. I just want to know if I can power the rail of edge or send power separately, since there is not enough info on how to power edge for servo use. (It’s similar for OPTO ESC)


(Marc Lebret) #12

Not really,

ESC circuit is powered by the battery. Some ESC are “real opto” and need an external power source (BEC on the servo rail to work) but it is quite uncommon. As soon your ESC is singing when the battery rail is connected, no need to separate power.

You can connect a 5Volt BEC to the servo rail, but it is not needed for the esc, only for servo or external accessories like led or photo trigger.

Marc


(Antonios Antzoulatos) #13

Checked specs on DYS web and it says BEC: OPTO. Many years ago I had similar issues with an airplane opto controller that would only “reboot” after high power requests and it was solved by powering it through Bec. I send email to DYS asking if power is needed from servo lead and I will also test on one of the esc in the morning


(Antonios Antzoulatos) #15

@mlebret,

After talking to DYS almost all day i finally got a reply that for these ESC to work properly they must be powered from 5v since they dont have a BEC circuit. I suppose that sevo rail power means i must connect the BEC to the Sbus OUt GND and PWR cables only. but i was scrolling through the docs and i could not find definetive doc on this.


(Marc Lebret) #16

Hello,

Plug the BEC on one Servo Out (like 9 or more) or your sBus Out (Ground and Power 5V). On my Hexa Edge, I use out 7.

SBus receiver in is powered 5V from the Edge to the receiver. There is no link with the servo rail (Out 1 to 12 or sBus Out).

Marc