Edge red led

I have an edge drone controller on a plane. I never flew with the airplane,
I am still working on it.Edge is new. Today, when I conected the batery I had an error
on the controller. Red light is flasing. It is not red solid. Led status ( https://docs.emlid.com/edge/led-status/ ) say that is a problemwith Gyros Initialiazation. Any ideas? what to do? everything is stoped.
Thank you for the help

Hi @jhonmuscalu,

Could you please share your hardware setup photos?

Yes Tatiana.


The red led is not solid

@jhonmuscalu,

Have you already gone through Edge Quickstart video tutorial?

ofcourse. everything worked fine untill…now. if i change the frame in qgc, let say quad, i dont have the red led. when change back to fix wing again the same problem. i have an error log, something like 201902206-131724.

@jhonmuscalu,

Did you change anything in settings?
Did you accomplish all the calibrations?

I did the calibrations before the problem. I try to do again now and have this.

If I change the air frame it seems to be ok. If the frame is hexa all the calibration was succesfuly. Back
on fixed wing, error is again.

what about this parameter? Can I load it from somewhere?

I reinstaled the firmware, but no luck. The controller works fine in multirotor mode and when is change in fixed wing everything is blocked. Is there a way to do a factory reset and then reinstall the firmware?

Hi @jhonmuscalu,

What’s your Edge version? You can find it in QGC, just click the button I marked with red on the screenshot below. Edge version should be specified in the first string:

Please also provide me with the version of QGC you use.

Thanks!

Hello,

You can do that with Etcher,
https://docs.emlid.com/edge/dev/firmware-update/

Marc

That is a PrtSc

Hi Marc.
I installed Etcher. It worked very well. I flasht once again the firmware but the rezult is the same.
How can i do the factory reset? It is necesary to flash a lower version than 1.5 of the firemware?

Hi @jhonmuscalu,

May I ask you to reset all settings to default in QGC? You can find this option in Parameters/Tools:

Please inform us about the result.

I tried everything (reset all settings to default, reinstall the firmware, etc). But the ideea Marc gived to me still was in my head.
So, after i installed all necesary to run Etcher i flashed the firmware once again and again no luck.The contoller worked fine in multirotor mode and when i swiched back to fixed wing, error again. I needed a factory reset. So i download an image from net (I could have created it but was simple to download) and flashed it with Etcher. After finishing flashing the unknown image, imidiatly i flashed the image with our firmware. And now everything is ok.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.