Drone shoots up in the air

May be. I do not find any information about Frsky x7r receiver?

Frsky sBus receivers are available.

Is there anyway to use sbus without soldering? I have heard a lot of complaints about sbus

There is only one servo line between receiver and Navio2 (the same one you use between your PPM encoder and the Navio2.

Here is a pic of the sbus outlets on the receiver.

sBus Out is the Green place (second closest to the antenna)

You can still use + and - lines from the servo out side and move only signal line to this place.

should I use jumper cables?

Does the transmitter require a microSD? I have been using it without

Read again doc from first link. At the end of page 2, there is an indication…

is it necessary for me to adjust the spring tension?

I followed the guide and I have the same problem. I updated the firmware, set the mode to 2 (already was 2), used AETR, calibrated the sticks directly using the transmitter. The x7 now has a voice lol. But the problem remains. Kinda. I noticed something interesting. When I recalibrate my ESCs, they seem to be working as expected. They dont spin too quickly. However, when I turn off and on my drone, it reverts back to my original problem.

BTW, does setting AETR require any configuration from the navio itself?

When doing radio calibration, AETR is normally identified by Navio. Can you share the latest registered log with your updated configuration. So we can check if modifications are doing something.

Did you change to sBus out from receiver?

1 Like

I am still using ppm because my jumper cables dont stay in the receiver’s holes so I cant really use sbus

So I posted some stuff in this other thread. https://community.emlid.com/t/insta-flip-problem

The main takeaway is that I tried modifying the expo and weight of the throttle channel and although it shots up at a different throttle position, the problem remains.

My motors are racerstars:
https://m.racerstar.com/Racerstar-Racing-Edition-2205-BR2205-2300KV-2-4S-Brushless-Motor-Red-CW-or-CCW-for-220-250-RC-Drone-FPV-Racing-p-33.html
My propellers are 8045s


My Escs is a 4 in 1

Here is a video. I should also mention that I checked the 4 main channels via qgroundcontrol. Like throttle is changed by moving the left stick vertically and yaw is changed by moving that stick horizontally.

I do not know Taranis settings, but the common rule is to use basic setup (regardless of brand). You can twitch expo with arducopter setup (default is 0.65).

When looking at your motor-propellers choice, there is a bad one. Such motor is to work with 5" propellers with a small size “race” quadcopter.

You can use your 8" props but such nervous flight is expected.

When choosing propulsion system, we expect to maintain constant altitude with 50% throttle. There is a parameter to adjust throttle hover.

But does it explain why it shoots up like that? I was talking to a drone enthusiast and he said that climbing can be attributed to software issues not a mismatch.

From the beginning of your quest, there are some multiple issues with:

Your RC transmitter settings,
Your receiver wiring choice,
Your hardware choice (frame-motors-propellers) not coherent with your goal,
Your interaction with the software

RC Tx settings and Rx wiring can be fixed. You have to do it before moving forward.

You can do with the hardware, it is not the easy way. For your “next” project, there is a tool: eCalc https://www.ecalc.ch/xcoptercalc.php

Arducopter need a lot of reading and understanding. When somewhere in the wiki, you read that you need to reverse Pitch command in the TX settings, you do it. You do not do it in the arducopter Pitch settings (according to your latest log parameter reading, you need to fix that point).

01

In your motor setting, MOT_HOVER_LEARN is selected.

25

You have to fly in hover with steady altitude during a while and tame your throttle control before MOT_THST_HOVER is adjusted. At the end, you may have a value around 0.25 or less.

… a lot of work, one step at a time…

1 Like